1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
|
Description: add /usr/bin to "search path" for timed-process script.
During build, bin/timed-process.PL is converted to bin/timed-process
which is then used during tests.
During autopkgtests, this conversions doesn't happen, and we want to test the
installed script in /usr/bin anyway.
Origin: vendor
Forwarded: not-needed
Author: gregor herrmann <gregoa@debian.org>
Last-Update: 2023-04-21
@@ -31,7 +31,7 @@
# script takes a sleep time and an exit value. timed-process takes a
# sleep time and a command to run.
my $sleep_exit;
-foreach my $dir (qw(. ./bin ./t ../bin ../t Proc-Background/t)) {
+foreach my $dir (qw(. ./bin ./t ../bin ../t Proc-Background/t /usr/bin)) {
unless ($sleep_exit) {
my $s = "$dir/sleep_exit.pl";
$sleep_exit = $s if -r $s;
@@ -18,7 +18,7 @@
# sleep time and a command to run.
my $sleep_exit;
my $timed_process;
-foreach my $dir (qw(. ./bin ./t ../bin ../t Proc-Background/t)) {
+foreach my $dir (qw(. ./bin ./t ../bin ../t Proc-Background/t /usr/bin)) {
unless ($sleep_exit) {
my $s = "$dir/sleep_exit.pl";
$sleep_exit = $s if -r $s;
|