File: changelog

package info (click to toggle)
libproxy 0.4.15-5
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 916 kB
  • sloc: cpp: 3,811; ansic: 112; makefile: 78; cs: 69; python: 44; perl: 42; sh: 17; ruby: 8
file content (438 lines) | stat: -rw-r--r-- 16,491 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
libproxy (0.4.15-5) unstable; urgency=medium

  * Add -Wl,-O1 to our LDFLAGS
  * Bump Standards-Version to 4.3.0

 -- Jeremy Bicha <jbicha@debian.org>  Fri, 28 Dec 2018 20:21:13 -0500

libproxy (0.4.15-4) unstable; urgency=medium

  * Build the mozjs plugin against mozjs 60 and limit the architectures where
    the package is built as mozjs 60 FTBFS on several architectures (Closes:
    #912940)

 -- Laurent Bigonville <bigon@debian.org>  Mon, 24 Dec 2018 15:33:14 +0100

libproxy (0.4.15-3) unstable; urgency=medium

  * Reintroduce libproxy1-plugin-mozjs, the module now builds with mozjs 52
  * debian/control.in: Drop X-Python(3)-Version to please lintian
  * debian/control.in: Bump Standards-Version to 4.2.1 (no further changes)
  * debian/rules: Use DEB_VERSION_UPSTREAM instead of SHLIBVER for the helpers

 -- Laurent Bigonville <bigon@debian.org>  Sat, 06 Oct 2018 07:40:35 +0200

libproxy (0.4.15-2) unstable; urgency=medium

  [ Helmut Grohne ]
  * Demote python Build-Depends to Build-Depends-Indep (Closes: #909211)

 -- Jeremy Bicha <jbicha@debian.org>  Wed, 19 Sep 2018 19:04:50 -0400

libproxy (0.4.15-1) unstable; urgency=medium

  * New upstream release
  * Update Vcs fields for migration to https://salsa.debian.org/
  * Drop libproxy1-plugin-mozjs since it depends on an outdated version
    of mozjs. Use libproxy1-plugin-webkit instead. (Closes: #863783)
  * Drop fix-clean-reload-cache.patch: Applied in new release

 -- Jeremy Bicha <jbicha@debian.org>  Wed, 28 Mar 2018 13:06:45 -0400

libproxy (0.4.14-4) unstable; urgency=medium

  * Update Vcs fields for conversion to git
  * Add debian/gbp.conf
  * Update Maintainer
  * Bump debhelper compat to 11
  * Bump Standards-Version to 4.1.2

 -- Jeremy Bicha <jbicha@debian.org>  Mon, 18 Dec 2017 17:07:44 -0500

libproxy (0.4.14-3) unstable; urgency=medium

  [ Alexander Volkov ]
  * Don't build depend on libkf5config-bin on stage1 (Closes: #847365)

 -- Laurent Bigonville <bigon@debian.org>  Sat, 27 May 2017 14:13:41 +0200

libproxy (0.4.14-2) unstable; urgency=medium

  * debian/patches/fix-clean-reload-cache.patch: Make sure that the PAC/WPAD
    cache is cleanup when network topology changes and prevent a segfault in
    the process, patches merged upstream.

 -- Laurent Bigonville <bigon@debian.org>  Wed, 08 Feb 2017 12:17:50 +0100

libproxy (0.4.14-1) unstable; urgency=medium

  * New upstream release.
  * Switch Build-Depends from network-manager-dev to the newer libnm-dev.
    While the code has a fallback for the older header files, the new ones
    provided by libnm are preferred by upstream.
  * Use DEB_LDFLAGS_MAINT_APPEND to pass additional flags to the linker.
  * Bump SHVER to 0.4.14.

 -- Michael Biebl <biebl@debian.org>  Sun, 22 Jan 2017 13:58:45 +0100

libproxy (0.4.13-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Fix FTBFS (Closes: #844956).

 -- Andrey Rahmatullin <wrar@debian.org>  Sun, 20 Nov 2016 14:24:11 +0500

libproxy (0.4.13-1) unstable; urgency=medium

  * Team upload.

  [ Michael Biebl ]
  * Drop uploaders.mk from debian/rules as this breaks the clean target with
    dh. Instead use the gnome dh addon which updates debian/control via
    dh_gnome_clean.

  [ Jeremy Bicha ]
  * New upstream version
  * Add python3-libproxy package
  * Add debian/docs to install NEWS
  * debian/control.in debian/watch: Update homepage and watch URLs
  * debian/control.in:
    - Build-depend on libkf5config-bin instead of QT and KDE libs
    - Bump Standards-Version to 3.9.8
  * debian/libproxy1-plugin-kconfig.install:
    config_kde.so instead of config_kde4.so
  * Dropped patches applied in new version:
    - 0001-pacrunner_webkit-allow-linking-against-javascriptcor.patch
    - dont_segfault_on_exit.patch
    - fix-mozjs-detection.patch

  [ Iain Lane ]
  * debian/rules: Use pyversions -d

 -- Jeremy Bicha <jbicha@linux.com>  Thu, 10 Nov 2016 12:57:09 +0000

libproxy (0.4.11-5) unstable; urgency=medium

  [ Peter Pentchev ]
  * Add explicit zlib build-dependency (Closes: #758465)
  * Break a couple of build dependency loops (Closes: #758466)
  * Add build profile annotations to debian/control (Closes: #758467)

  [ Andreas Henriksson ]
  * Build-depend on dpkg-dev (>= 1.17.2) and bump debhelper to >= 9.20140227
    - these versions introduced build profiles support.
  * Bump Standards-Version to 3.9.5

  [ Iain Lane ]
  * Ack the NMUs, thanks!
  * Fix the build profiles syntax to the current version.
  * debian/patches/0001-pacrunner_webkit-allow-linking-against-javascriptcor.patch:
    Cherry-pick - allow building against webkit2gtk. Update BDs too.
  * Add Enhances: from the plugin packages to the library so that people can
    find them easier. (Closes: #768435, #768437)
  * Use the substvar we just added to add Depends on our shared package.

 -- Iain Lane <laney@debian.org>  Tue, 16 Feb 2016 13:17:41 +0000

libproxy (0.4.11-4.2) unstable; urgency=medium

  * Non maintainer upload.
  * libproxy1-plugin-mozjs: Fix dependency on new libproxy1v5.

 -- Matthias Klose <doko@debian.org>  Tue, 04 Aug 2015 21:42:23 +0200

libproxy (0.4.11-4.1) unstable; urgency=medium

  * Non maintainer upload.
  * Rename library libproxy1 -> libproxy1v5, needed as a follow-up transition
    for the libstdc++6 ABI changes (patch by Sebastien Bacher).
    Addresses: #794402.

 -- Matthias Klose <doko@debian.org>  Tue, 04 Aug 2015 20:15:37 +0200

libproxy (0.4.11-4) unstable; urgency=low

  * Upload to unstable

 -- Laurent Bigonville <bigon@debian.org>  Sun, 03 Nov 2013 13:34:28 +0100

libproxy (0.4.11-3) experimental; urgency=low

  * debian/control.in: Build-depend on netbase, this will hopefully fix the
    FTBFS

 -- Laurent Bigonville <bigon@debian.org>  Thu, 10 Oct 2013 16:06:21 +0200

libproxy (0.4.11-2) experimental; urgency=low

  * debian/control.in: Only build networkmanager plugin on linux-any
    architectures
  * Drop debian/libproxy1.symbols: .symbols file with C++ libraries is just a
    nightmare, rely on the good old shlibs file

 -- Laurent Bigonville <bigon@debian.org>  Sat, 28 Sep 2013 13:34:14 +0200

libproxy (0.4.11-1) experimental; urgency=low

  * Upload new upstream release to debian, thanks to the Ubuntu guys for the
    changes (Closes: #604934)
  * Re-enable mozjs plugin, this new version is built against mozjs185, this
    fix the current FTBFS and the stability of the ABI/API we build against
    (Closes: #707419, #722685)
  * debian/rules:
    - Re-add uploaders.mk magic
    - Bump SHLIBVER to 0.4.11
    - Make the build fails if symbols are missing the .symbols file
  * debian/patches/fix-mozjs-detection.patch: Properly detect mozjs, patch
    from upstream VCS.
  * debian/libproxy1.symbols: Add symbols file
  * debian/watch: Update to work with Google Code website, again.
  * debian/proxy.1, debian/libproxy-tools.manpages: Install a manpage for the
    proxy command (Closes: #660327)

 -- Laurent Bigonville <bigon@debian.org>  Sat, 14 Sep 2013 15:35:03 +0200

libproxy (0.4.11-0ubuntu2) saucy; urgency=low

  * debian/patches/dont_segfault_on_exit.patch:
    - drop buggy unref calls to fix a segfault (lp: #1182043)

 -- Sebastien Bacher <seb128@ubuntu.com>  Thu, 30 May 2013 13:20:43 +0200

libproxy (0.4.11-0ubuntu1) raring; urgency=low

  * New upstream release
    - Build fixes with cmake 2.8.10+
    - Quick release without built binaries / files
      + Remove these from debian/clean
  * debian/watch: Update to work with current Google Code website (once more
    with feeling)

 -- Iain Lane <iain.lane@canonical.com>  Thu, 10 Jan 2013 12:17:22 +0000

libproxy (0.4.10-0ubuntu1) raring; urgency=low

  * New upstream release 0.4.10 (LP: #1078915). Selected fixes since 0.4.7:
    - Fix infinite loop uppon network errors
    - Only support standalone mozjs185 as mozilla js engine.  xulrunner being
      part of the now lightning fast moving firefox is impossible to be tracked
      as a dependency and it is not supported by Mozilla to be used in this
      scenario.
    - Support building with javascritpcoregtk 1.5 (got split out of webkitgtk).
  * debian/watch: Update to work with Google code again .
  * Remove all patches - all applied upstream.
  * Clean accidently shipped built binaries to ensure we ship those built from
    this source.
  * debian/patches/disable-pac-test.patch: Steal patch from Gentoo to disable
    the get-pac-test which hangs when run from the build.
  * Bump Standards-Version to 3.9.4, no changes required.
  * Add basic compile/link/run autopkgtest - thanks to Rafal Cieślak (LP:
    #1079102)

 -- Iain Lane <iain.lane@canonical.com>  Thu, 15 Nov 2012 12:06:57 +0000

libproxy (0.4.7-0ubuntu6) quantal; urgency=low

  * debian/patches/CVE-2012-4504.patch: Cherry-pick upstream r853 to fix
    buffer overflow when downloading large PAC files.

 -- Iain Lane <iain.lane@canonical.com>  Wed, 10 Oct 2012 17:56:14 +0100

libproxy (0.4.7-0ubuntu5) quantal; urgency=low

  * debian/patches/libproxy-gcc-4.7.diff: Cherry-pick patch from upstream svn
    r833 to fix FTBFS with GCC-4.7 due to missing includes.

 -- Iain Lane <iain.lane@canonical.com>  Tue, 25 Sep 2012 12:51:03 +0100

libproxy (0.4.7-0ubuntu4) precise; urgency=low

  * Re-enable webkit pacrunner and build it into its own module package
    (adding a patch to the upstream build system required to achieve this).
    (LP: #934088)
  * Build with webkit3.

 -- Iain Lane <laney@ubuntu.com>  Fri, 17 Feb 2012 10:10:45 +0000

libproxy (0.4.7-0ubuntu3) precise; urgency=low

  * Drop libwebkitgtk-dev build dependency. We just got rid of the old
    webkit-gtk2 stack, we don't want to pull that back in. We already had to
    disable the webkit plugin as this needs mozjs. (LP: #933913)

 -- Martin Pitt <martin.pitt@ubuntu.com>  Fri, 17 Feb 2012 07:54:22 +0100

libproxy (0.4.7-0ubuntu2) precise; urgency=low

  * debian/control: Drop mozjs build dependency and mozjs/webkit plugin
    packages, mozjs is in universe (and supposed to stay there).
  * debian/rules: Disable WITH_MOZJS.

 -- Martin Pitt <martin.pitt@ubuntu.com>  Wed, 15 Feb 2012 16:21:24 +0100

libproxy (0.4.7-0ubuntu1) precise; urgency=low

  [ Iain Lane ]
  * New upstream release.
  * Convert to dh7.
  * SONAME bump, rename packages accordingly
  * Remove obsolete patches
  * Add CLI/Vala bindings.
  * Also install vala bindings (in -dev package)
  * Update Standards-Version to 3.9.2
  * Split modules into individual packages
  * Link with --as-needed to avoid unnecessary deps
  * Update copyright
  * Make library multiarch compatible

  [ Ken VanDine ]
  * Build against libmozjs185.

 -- Iain Lane <laney@debian.org>  Wed, 15 Feb 2012 14:42:54 +0100

libproxy (0.3.1-6) unstable; urgency=low

  * Swap libmozjs and webkitgtk Recommends. Closes: #699788.

 -- Josselin Mouette <joss@debian.org>  Tue, 05 Feb 2013 08:59:26 +0100

libproxy (0.3.1-5.1) unstable; urgency=high

  * Non-maintainer upload.
  * Fix cve-2012-4505: buffer overflow in lib/pac.c (closes: #690376).

 -- Michael Gilbert <mgilbert@debian.org>  Sat, 27 Oct 2012 04:44:22 -0400

libproxy (0.3.1-5) unstable; urgency=low

  [ Kees Cook ]
  * debian/{control,rules,*.install}: Convert to Multi-Arch. Closes: #651491

  [ Michael Biebl ]
  * Bump Standards-Version to 3.9.3.
  * Update Vcs-* URLs.

 -- Michael Biebl <biebl@debian.org>  Fri, 18 May 2012 21:12:36 +0200

libproxy (0.3.1-4) unstable; urgency=low

  * debian/patches/03_format-security.patch:
    - Fix build failure with [-Werror=format-security]. Closes: #643433
  * Bump debhelper compatibility level to 8.
    - Update Build-Depends on debhelper.
    - Strip debian/tmp/ from .install files.
  * Don't hard-code the Recommends on libwebkitgtk-1.0-0 | libmozjs6d.
    Instead filter out the correct library package names as found by
    dpkg-shlibdeps and set them via substvars.
  * Bump Standards-Version to 3.9.2. No further changes.

 -- Michael Biebl <biebl@debian.org>  Tue, 25 Oct 2011 03:28:17 +0200

libproxy (0.3.1-3) unstable; urgency=low

  * Use linux-any wildcard. Closes: #634464.
  * Migrate to libwebkitgtk* dependencies. Closes: #635416.
  * Migrate to dh_python2. Closes: #635140.
  * Build-depend on mozjs >= 6, require libmozjs6d. Closes: #638942.
  * Switch to 3.0 quilt format.
  * 02_url_user.patch: patch from Florian Echtler to fix incorrect
    parsing of URLs containing user and port but no password.
    Closes: #635684.

 -- Josselin Mouette <joss@debian.org>  Tue, 23 Aug 2011 23:11:55 +0200

libproxy (0.3.1-2) unstable; urgency=low

  [ Emilio Pozuelo Monfort ]
  * debian/patches/libproxy_link_against_libdl.patch:
    - Removed, configure.ac already adds the correct check so this is not
      needed anymore.

  [ Josselin Mouette ]
  * 01_pac_http.patch: new patch from Julien Blache. Don’t assume HTTP
    header names are case sensitive. Closes: #600196.
  * Re-enable webkit support. The build-dependency loop is not a problem
    for a stable release. (But the issue will arise again later.)
  * Recommend libwebkit-1.0-2 | libmozjs2d. Closes: #597864.

 -- Josselin Mouette <joss@debian.org>  Tue, 19 Oct 2010 08:46:05 +0200

libproxy (0.3.1-1) unstable; urgency=low

  * New upstream release.
    - Fixes crash when parsing .pac file. Closes: #550179.
    - debian/patches/10_configure-check-for-dbus.patch,
      debian/patches/60_am-prog-cc-c-o.patch:
      + Removed, fixed upstream.
    - debian/control.in:
      + Build depend on gconf2 instead of libgconf2-dev.
      + Build depend on kdelibs5-dev and libqt4-dev for the KDE4 plugin.
    - debian/patches/50_px-wpad-fallback-env-var.patch,
      debian/rules:
      + Remove patch, don't install wpad_dnsdevolution.so now.
    - debian/patches/70_autotools.patch:
      + Removed, no longer needed.
    - debian/libproxy0.install,
      debian/rules:
      + s/plugins/modules/ following the upstream change.
  * debian/control.in:
    - Update my maintainer email address.
    - Standards-Version is 3.8.3, no changes needed.
    - libproxy-tools is section utils.
  * debian/watch:
    - Look for bzip2 tarballs.
  * debian/patches/libproxy_link_against_libdl.patch:
    - Link with -ldl for dlopen et al. Closes: #558920.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Sat, 12 Dec 2009 01:56:54 +0100

libproxy (0.2.3-4) unstable; urgency=low

  * Don't build NetworkManager support on non-Linux platforms. Thanks
    Samuel Thibault. Closes: #534939.
  * Standards-Version is 3.8.2, no changes needed.

 -- Emilio Pozuelo Monfort <pochu@ubuntu.com>  Sun, 28 Jun 2009 20:35:04 +0200

libproxy (0.2.3-3) unstable; urgency=low

  * Stop building the webkit plugin for now, we have a circular build-
    dependency with webkit. Instead, build the mozjs one, so that we can
    still read PAC files.

 -- Emilio Pozuelo Monfort <pochu@ubuntu.com>  Wed, 29 Apr 2009 20:55:50 +0200

libproxy (0.2.3-2) unstable; urgency=low

  * debian/patches/50_px-wpad-fallback-env-var.patch:
    - Fix logic to not bypass the config plugin when the env variable
      isn't set. We don't do wpad fallback if the env variable isn't set,
      but there's not reason to ignore the config file if one is provided.
      See https://launchpad.net/bugs/354475.
  * Standards-Version is 3.8.1, no changes needed.
  * debian/copyright: Add copyright note for pacutils.js

 -- Emilio Pozuelo Monfort <pochu@ubuntu.com>  Sat, 25 Apr 2009 14:25:10 +0200

libproxy (0.2.3-1) unstable; urgency=low

  [ Emilio Pozuelo Monfort ]
  * Initial release (Closes: #509063).
  * Fix if/else logic and a wrong free in 50_px-wpad-fallback-env-var.

  [ Loic Minier ]
  * Set libproxy-dev Arch: any; too small win to warrant installability issues
    on slow arches.
  * Drop shlibs:Depends from python-libproxy as it's Arch: all.
  * Drop gnome-get-source.mk include as it's not working by default.
  * Rename patch configure_check_for_dbus to 10_configure-check-for-dbus.
  * Run a full autoreconf instead of only autoconf.
    - New patch, 60_am-prog-cc-c-o, makes newer autoconfs happier.
    - New patch, 70_autotools, split autotools generated files here to force
      them to be applied last and avoid timestamp skews issues.
    Thanks Sébastien Bacher and Ubuntu for the above.
  * New patch, 50_px-wpad-fallback-env-var, check PX_WPAD_FALLBACK env var to
    decide whether to fall back to wpad:// style autodetection or not,
    defaulting to not fallback when the env var isn't set.

 -- Emilio Pozuelo Monfort <pochu@ubuntu.com>  Tue, 03 Mar 2009 01:11:35 +0100