File: changelog

package info (click to toggle)
libpwiz 3.0.18342-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 14,888 kB
  • sloc: cpp: 157,552; sh: 4,182; makefile: 317
file content (230 lines) | stat: -rw-r--r-- 7,787 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
libpwiz (3.0.18342-2) unstable; urgency=low

  * Improve header path (move pwiz to proteowizard) to ease with nested
    directories.

 -- Filippo Rusconi <lopippo@debian.org>  Fri, 01 Feb 2019 23:38:03 +0100

libpwiz (3.0.18342-1) unstable; urgency=low

  * New upstream release. Note that for this release (and later, probably),
    the pwiz package was crafted by me according to instructions and the bjam
    build system that is used upstream.

  * Remove the nnls.h patch as this file is now shipped in the source tarball.

  * debian/rules: update to tweak the Makefile (include directories) and
    BOOST_LDPATH.

  * Update the Vcs-* fields to match the salsa-based URLs.

  * Set Priority: to optional (not extra).

  * Update d/copyright for the libraries/Eigen/nnls.h file.

  * Standards-Version: 4.2.1: no changes required.

 -- Filippo Rusconi <lopippo@debian.org>  Fri, 07 Dec 2018 13:27:42 +0100

libpwiz (3.0.10827-4) unstable; urgency=medium

  * debian/make-included-headers-hierarchy.sh: fix script to avoid adding
    non-useful h[pp] files. Thanks to Adam Borowski <kilobyte@angband.pl>
    for reporting the bug (Closes:#878616).

 -- Filippo Rusconi <lopippo@debian.org>  Wed, 01 Nov 2017 16:08:32 +0100

libpwiz (3.0.10827-3) unstable; urgency=medium

  * debian/control: Replace tabs with spaces. 

  * debian/control: fix libboost-dev dependency so that
    /usr/include/boost/lexical_cast.hpp is there although the library 
    fine even without it, it is required by dependencies.

 -- Filippo Rusconi <lopippo@debian.org>  Wed, 05 Jul 2017 20:25:53 +0200

libpwiz (3.0.10827-2) unstable; urgency=medium

  * debian/control: add dependency to libbost-dev. 

 -- Filippo Rusconi <lopippo@debian.org>  Sat, 01 Jul 2017 22:52:58 +0200

libpwiz (3.0.10827-1) unstable; urgency=medium

  * New upstream version.

  * debian/control Standards-Version: 4.0.0

  * Use the trigger infrastructure to call ldconfig.
  
  * debian/copyright: thorough rework using licensecheck  + manual checking.

 -- Filippo Rusconi <lopippo@debian.org>  Tue, 27 Jun 2017 10:17:49 +0200

libpwiz (3.0.9393-1) unstable; urgency=medium

  * New upstream version.

  * debian/rules: remove the clean target from the configure target.

  * debian/control Standards-Version: 3.9.7 (no changes)

 -- Filippo Rusconi <lopippo@debian.org>  Mon, 21 Mar 2016 16:33:44 +0100
 
libpwiz (3.0.8789-1) unstable; urgency=medium

  * New upstream version.

  * debian/control:
    Build-Depends: add libboost-chrono-dev
    Standards-Version: 3.9.6

  * libpwiz.lintian-overrides: add a bunch of overrides.

  * debian/rules: add some shell code to set the BOOST_LDPATH to the
    proper architecture-dependent lib path.

 -- Filippo Rusconi <lopippo@debian.org>  Fri, 02 Oct 2015 10:27:02 +0200

libpwiz (3.0.8642-1) unstable; urgency=medium

  * New upstream version.

 -- Filippo Rusconi <lopippo@debian.org>  Fri, 10 Jul 2015 13:56:17 +0200

libpwiz (3.0.6585-3) UNRELEASED; urgency=medium

  * debian/upstream/metadata: use correct bibtex syntax for authors list
    (thanks Andreas Tille <tille@debian.org>.

 -- Filippo Rusconi <lopippo@debian.org>  Mon, 09 Feb 2015 13:44:17 +0100

libpwiz (3.0.6585-2) unstable; urgency=medium

  * mv upstream upstream/metadata

 -- Filippo Rusconi <lopippo@debian.org>  Mon, 18 Aug 2014 11:44:11 +0200


libpwiz (3.0.6585-1) unstable; urgency=medium

  * New upstream version.
  
  * Patch to fix autotools-based boost-related glitches.

 -- Filippo Rusconi <lopippo@debian.org>  Wed, 13 Aug 2014 17:09:10 +0200

libpwiz (3.0.4624-10) unstable; urgency=medium

  * Fix the libpwiz: run dh-autoreconf to update config.{sub, guess} and
    {libtool, aclocal}.m4 bug reported by Breno Leitao
    (<brenohl@br.ibm.com>) (Closes: #748764).

 -- Filippo Rusconi <lopippo@debian.org>  Wed, 13 Aug 2014 15:21:21 +0200

libpwiz (3.0.4624-9) unstable; urgency=low

  * debian/rules: apply patch from Dejan Latinovic
    <Dejan.Latinovic@imgtec.com> to fix the build problem on mips/mipsel
    platforms that was not resolved as of version 3.0.4624-8. Closing bug,
    this time for good, hopefully. (Closes: #738137).
  
 -- Filippo Rusconi <lopippo@debian.org>  Sun, 02 Mar 2014 12:53:59 +0100

libpwiz (3.0.4624-8) unstable; urgency=low

  * debian/rules: remove the parallel build on mips and mipsel hosts to
    try to reduce memory exhaustion upon build (Closes: #738137). Thanks to
    Andreas Beckmann <anbe@debian.org> for reporting it and to Michael
    Banck <mbanck@debian.org> for sharing knowledge on dpkg-architecture
    features.

 -- Filippo Rusconi <lopippo@debian.org>  Tue, 11 Feb 2014 14:29:13 +0100

libpwiz (3.0.4624-7) unstable; urgency=low

  * remove libboost atomic stuff from the source directory at build-time
    so that the system-based libboost stuff is used instead. This mixing
    "local" source code with system-based libboost binaries was causing
    build failures. Thanks to Aurelien Jarno <aurelien@aurel32.net> for
    the forensic work around this build failure (Closes: #731064).

  * Standards-Version: 3.9.5.

 -- Filippo Rusconi <lopippo@debian.org>  Sat, 04 Jan 2014 23:53:45 +0100

libpwiz (3.0.4624-6) unstable; urgency=low

  * debian/control: add libpwiz-tools binary package to ship binaries that
    make use of libpwiz. Part of these binaries used to be shipped in
    /usr/lib/libpwiz3/example-files/, but that is a suboptimal setting
    (thanks to Olivier Langella for this input).
  * The example source code files have been moved from
    /usr/lib/libpwiz3/example-files/ to
    /usr/share/doc/libpwiz3/example-files/.

 -- Filippo Rusconi <lopippo@debian.org>  Wed, 04 Dec 2013 20:18:44 +0100

libpwiz (3.0.4624-5) unstable; urgency=low

  * Set Build-Depends libboost-*-dev to (>= 1.54.0) (Closes: #731064).

 -- Filippo Rusconi <lopippo@debian.org>  Wed, 04 Dec 2013 15:39:59 +0100

libpwiz (3.0.4624-4) unstable; urgency=low

  * debian/rules: Run dh_fixperms after generating the symbols and shlibs
    files so that the correct permissions are set for them also.  Lintian
    was complaining.

 -- Filippo Rusconi <lopippo@debian.org>  Fri, 15 Nov 2013 17:05:30 +0100

libpwiz (3.0.4624-3) unstable; urgency=low

  * debian/control: set entries in Build-Depends about Boost libs on
    unversioned -dev packages (Closes: #722189). This time rebuild the
    binary package.
  
 -- Filippo Rusconi <lopippo@debian.org>  Thu, 14 Nov 2013 10:24:59 +0100

libpwiz (3.0.4624-2) unstable; urgency=low

  * debian/control: set entries in Build-Depends about Boost libs on
    unversioned -dev packages (Closes: #722189).
  
 -- Filippo Rusconi <lopippo@debian.org>  Wed, 30 Oct 2013 20:53:16 +0100

libpwiz (3.0.4624-1) unstable; urgency=low

  * New upstream release (Closes: #693044);
  
  * debian/control: Vcs-Git and Vcs-Browser now use the canonical URIs;
  
  * debian/copyright : fixes to the format and made a general overview
    after new upstream release;
  
  * debian/control: Standards-Version: 3.9.4;
  
  * debian/control: add dependency on autotools-dev to lift the lintian
    warning complaining about outdated-autotools-helper-file
    autotools/config.guess 2006-07-02;
  
  * add #DEBHELPER# to libpwiz3.postinst to lift the lintian complaining
    that maintainer-script-lacks-debhelper-token debian/libpwiz3.postinst;
  
 -- Filippo Rusconi <lopippo@debian.org>  Thu, 29 Aug 2013 16:22:04 +0200

libpwiz (3.0.4098-2) UNRELEASED; urgency=low

  * Initial release (Closes: #693044).
  
  * Fix to the version of the license for the debian/* files.

 -- Filippo Rusconi <lopippo@debian.org>  Mon, 05 Nov 2012 21:37:18 +0100

libpwiz (3.0.4098-1) experimental; urgency=low

  * Initial release (Closes: #693044).

 -- Filippo Rusconi <lopippo@debian.org>  Mon, 05 Nov 2012 21:37:18 +0100