1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
|
include /usr/share/dpkg/pkg-info.mk
export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
%:
dh $@ --buildsystem=cmake
export LIBRDATA_VERSION=0.1.0
export LIBRDATA_SOVERSION=0
override_dh_clean:
dh_clean
rm -f $(CURDIR)/debian/RDataConfig.cmake
override_dh_auto_configure:
dh_auto_configure -- \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Debug \
-DCMAKE_SKIP_RPATH=1
rst2man debian/librdata.3.rst > debian/librdata.3
override_dh_auto_build:
dh_auto_build --no-parallel
|