1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53
|
Description: Remove unused MACHINE.
Without SYSROOT (see separate patch) MACHINE is mostly unused:
The only use is setting up CROSS_COMPILE and OS,
but these are supposed to be set by a user for cross compilation.
Removing this code makes win32 behave just like any other arch
and MACHINE can go in the bucket.
Author: Helmut Grohne <helmut@subdivi.de>
Bug-Debian: https://bugs.debian.org/911358
Last-Update: 2018-10-19
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
@@ -162,23 +162,10 @@
# OS section
#
-MACHINE := $(shell $(CC) -dumpmachine)
-
ifeq ($(CROSS_COMPILE),)
OS := $(shell uname -s | sed -e s/SunOS/solaris/ | tr "[A-Z]" "[a-z]")
endif
-
-ifneq ($(strip $(filter i386-mingw32 i486-mingw32 i586-mingw32msvc \
- i686-w64-mingw32 x86_64-w64-mingw32 mingw32, \
- $(MACHINE))),)
- OS := win32
-ifeq ($(MACHINE), mingw32)
- CROSS_COMPILE :=
-endif
-endif
-
-
# default
LIB_SUFFIX := .so
MOD_SUFFIX := .so
@@ -297,7 +284,6 @@
APP_LFLAGS += -Wl,--export-all-symbols
AR := ar
AFLAGS := cru
- CROSS_COMPILE ?= $(MACHINE)-
RANLIB := $(CROSS_COMPILE)ranlib
LIB_SUFFIX := .dll
MOD_SUFFIX := .dll
@@ -631,7 +617,6 @@
@echo "info - $(PROJECT) version $(VERSION)"
@echo " MODULES: $(MODULES)"
# @echo " SRCS: $(SRCS)"
- @echo " MACHINE: $(MACHINE)"
@echo " ARCH: $(ARCH)"
@echo " OS: $(OS)"
@echo " BUILD: $(BUILD)"
|