1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53
|
export DEB_CFLAGS_MAINT_STRIP=-Werror=implicit-function-declaration
DH_VERBOSE = 1
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
CFLAGS += -D_LARGE_FILE_SOURCE=1 -D_FILE_OFFSET_BITS=64
%:
ifeq (mipsel,$(findstring mipsel,$(DEB_HOST_ARCH)))
dh $@ --no-parallel
else ifeq (mips64el,$(findstring mips64el,$(DEB_HOST_ARCH)))
dh $@ --no-parallel
else
dh $@
endif
override_dh_auto_clean:
test -f Makefile.conf && dh_auto_clean || true
override_dh_auto_configure:
./configure \
--LDFLAGS='$(LDFLAGS)' \
--CFLAGS='$(CFLAGS) $(CPPFLAGS)' \
\
--symbols \
--prefix=/usr \
\
--all=disable \
--buildin-script \
--buildin-diag_rnd \
--buildin-lib_gensexpr \
--buildin-hid_batch \
--buildin-lib_portynet \
--buildin-lib_exp_text \
--buildin-import_pixmap_pnm \
--plugin-lib_hid_gl \
--plugin-lib_wget \
--plugin-lib_gtk4_common \
--plugin-lib_hid_common \
--plugin-import_pixmap_gd \
--plugin-hid_lesstif \
--plugin-hid_gtk4_gl \
--plugin-irc \
--plugin-lib_exp_pixmap \
|