1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
|
include /usr/share/gnome-pkg-tools/1/rules/gnome-get-source.mk
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-z,defs -Wl,-O1 -Wl,--as-needed
%:
dh $@ --with autoreconf,gnome,gir
override_dh_autoreconf:
dh_autoreconf --as-needed
override_dh_auto_configure:
dh_auto_configure -- \
--enable-pixbuf-loader \
--enable-introspection \
--enable-vala \
--enable-gtk-doc
override_dh_makeshlibs:
dh_makeshlibs -V -- -c4
override_dh_install:
dh_install
sed -e "s/#MULTIARCH#/$(DEB_HOST_MULTIARCH)/g" debian/librsvg2-common.postinst.in > \
debian/librsvg2-common.postinst
override_dh_clean:
dh_clean
rm -f debian/librsvg2-common.postinst
|