File: Makefile.PL

package info (click to toggle)
libscope-guard-perl 0.20-1
  • links: PTS, VCS
  • area: main
  • in suites: jessie, jessie-kfreebsd, squeeze, wheezy
  • size: 80 kB
  • ctags: 6
  • sloc: perl: 255; makefile: 2
file content (37 lines) | stat: -rw-r--r-- 1,257 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
use 5.006001;

use strict;
use warnings;

use ExtUtils::MakeMaker;

WriteMakefile1(
    MIN_PERL_VERSION => '5.006001',
    BUILD_REQUIRES   => {
        'Test::More' => 0,
    },
    NAME          => 'Scope::Guard',
    VERSION_FROM  => 'lib/Scope/Guard.pm',
    ABSTRACT_FROM => 'lib/Scope/Guard.pm',
    AUTHOR        => 'chocolateboy <chocolate@cpan.org>',
    LICENSE       => 'perl'
);

sub WriteMakefile1 { # Written by Alexandr Ciornii, version 0.21. Added by eumm-upgrade.
    my %params       = @_;
    my $eumm_version = $ExtUtils::MakeMaker::VERSION;
    $eumm_version = eval $eumm_version;
    die "EXTRA_META is deprecated" if exists $params{EXTRA_META};
    die "License not specified" if not exists $params{LICENSE};
    if ($params{BUILD_REQUIRES} and $eumm_version < 6.5503) {
        # EUMM 6.5502 has problems with BUILD_REQUIRES
        $params{PREREQ_PM} = { %{ $params{PREREQ_PM} || {} }, %{ $params{BUILD_REQUIRES} } };
        delete $params{BUILD_REQUIRES};
    }
    delete $params{MIN_PERL_VERSION}   if $eumm_version < 6.48;
    delete $params{LICENSE}            if $eumm_version < 6.31;
    delete $params{AUTHOR}             if $] < 5.005;
    delete $params{ABSTRACT_FROM}      if $] < 5.005;

    WriteMakefile(%params);
}