1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
|
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
LIBPKG := libseccomp2
DEVPKG := libseccomp-dev
export V=1
%:
dh $@ --parallel --with autoreconf
override_dh_auto_clean:
dh_auto_clean
rm -f regression.out
override_dh_link:
dh_link -p$(DEVPKG) \
lib/$(DEB_HOST_MULTIARCH)/$$(basename $$(readlink debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/libseccomp.so)) \
usr/lib/$(DEB_HOST_MULTIARCH)/libseccomp.so
dh_link --remaining-packages
override_dh_install:
dh_install -p$(LIBPKG) \
"usr/lib/$(DEB_HOST_MULTIARCH)/libseccomp.so.*" \
lib/$(DEB_HOST_MULTIARCH)
dh_install --remaining-packages --list-missing
override_dh_auto_test:
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
make check 2>&1 | tee regression.out && \
grep -q "^ tests failed: 0" regression.out || true
endif
|