File: Makefile.PL

package info (click to toggle)
libsendmail-pmilter-perl 1.00-1
  • links: PTS
  • area: main
  • in suites: bullseye, buster, jessie, jessie-kfreebsd, sid, stretch, wheezy
  • size: 184 kB
  • ctags: 110
  • sloc: perl: 1,046; makefile: 48
file content (32 lines) | stat: -rw-r--r-- 1,148 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
# $Id: Makefile.PL,v 1.3 2004-08-14 18:09:38 bengen Exp $

use 5.006;
use ExtUtils::MakeMaker;

my $install = ( ExtUtils::MakeMaker::prompt(<<EOT . 'Do you wish to install the Sendmail::Milter interface?' => 'yes' ) =~ /^\s*(y)/i );

The Sendmail::PMilter distribution includes a module that supplies a 
compatibility interface emulating the standard Sendmail::Milter API,
rather than using the native libmilter (which is not compatible
with modern Perl threads).

Choose "no" below ONLY IF the standard Sendmail::Milter package is
installed or will be installed.  Otherwise, the compatibility
interface MUST be installed, as it is needed for Sendmail::PMilter
to function properly.

EOT

my %PM = (
        'lib/Sendmail/PMilter.pm'           =>  '$(INST_LIBDIR)/PMilter.pm',
        'lib/Sendmail/PMilter/Context.pm'   =>  '$(INST_LIBDIR)/PMilter/Context.pm'
);
$PM{'lib/Sendmail/Milter.pm'} = '$(INST_LIBDIR)/Milter.pm' if $install;

WriteMakefile(
    ABSTRACT_FROM	=> 'lib/Sendmail/PMilter.pm',
    AUTHOR		=> 'Todd Vierling <tv@duh.org>',
    PM			=>  \%PM,
    NAME		=> 'Sendmail::PMilter',
    VERSION_FROM	=> 'lib/Sendmail/PMilter.pm',
);