1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
export DPKG_GENSYMBOLS_CHECK_LEVEL = 4
built_binaries := $(shell dh_listpackages)
ifeq (linux,$(DEB_HOST_ARCH_OS))
SYSPROF = -Dsysprof=enabled
else
SYSPROF = -Dsysprof=disabled
endif
ifneq ($(filter nocheck,$(DEB_BUILD_OPTIONS))$(filter %-tests,$(built_binaries)),nocheck)
test_features = enabled
else
test_features = disabled
endif
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- \
-Dauto_features=enabled \
-Dautobahn=disabled \
-Dinstalled_tests=true \
-Dpkcs11_tests=$(test_features) \
$(SYSPROF)
override_dh_auto_test-arch:
dh_auto_test -- --timeout-multiplier 6
override_dh_fixperms:
dh_fixperms -Xusr/libexec/installed-tests
ifneq ($(filter %-tests,$(built_binaries)),)
chmod --changes u=rw,og=r debian/*-tests/usr/libexec/installed-tests/libsoup*/*.so
chmod --recursive --changes a+rX,u+w,og-w debian/*-tests/usr/libexec/installed-tests
endif
override_dh_gnome_clean:
dh_gnome_clean --no-control
|