File: perlcritic.t

package info (click to toggle)
libtest-script-run-perl 0.08-2
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, buster, sid
  • size: 240 kB
  • sloc: perl: 2,474; makefile: 2
file content (16 lines) | stat: -rw-r--r-- 409 bytes parent folder | download | duplicates (4)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
use strict;
use warnings;

use Test::More;

# we forced use Perl::Critic is for version limit
eval "use Perl::Critic 1.090; use Test::Perl::Critic 1.01";
if ($@) {
    plan skip_all =>
"Perl::Critic 1.090 and Test::Perl::Critic 1.01 required for testing PBP compliance";
}
elsif ( !-e 'inc/.author' ) {
    plan skip_all => 'no inc/.author, will not run this test ;)';
}

Test::Perl::Critic::all_critic_ok();