File: Makefile.PL

package info (click to toggle)
libtest-spec-perl 0.54-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 312 kB
  • sloc: perl: 2,502; makefile: 2
file content (46 lines) | stat: -rw-r--r-- 1,625 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
use 5.008005;
use ExtUtils::MakeMaker;
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
# the contents of the Makefile that is written.
my %MM_ARGS = (
    NAME              => 'Test::Spec',
    VERSION_FROM      => 'lib/Test/Spec.pm', # finds $VERSION
    PREREQ_PM         => {
      'Carp'           => 0,
      'Exporter'       => 0,
      'List::Util'     => 0,
      'Package::Stash' => 0.23,
      'Scalar::Util'   => 1.11,
      'Test::Deep'     => 0.103, # earlier versions clash with UNIVERSAL::isa
      'Test::More'     => 0.88,
      'Test::Trap'     => 0,
      'Tie::IxHash'    => 0,
      'constant'       => 0,
    },
    TEST_REQUIRES => {
      'TAP::Parser'        => 0,
      'Devel::GlobalPhase' => 0,
    },
    ABSTRACT_FROM  => 'lib/Test/Spec.pm', # retrieve abstract from module
    AUTHOR         => 'Philip Garrett <philip.garrett@icainformatics.com>',
    LICENSE => 'perl',
    META_MERGE        => {
        'meta-spec' => { version => 2.0 },
        resources => {
            repository => {
                type => 'git',
                web => 'https://github.com/kingpong/perl-Test-Spec',
                url => 'https://github.com/kingpong/perl-Test-Spec',
            },
            bugtracker => {
                web => 'https://github.com/kingpong/perl-Test-Spec/issues',
            },
        },
    },
);

$MM_ARGS{BUILD_REQUIRES} = {%{$MM_ARGS{BUILD_REQUIRES}}, %{delete $MM_ARGS{TEST_REQUIRES}}}
  if $eumm_version < 6.63_03;
$MM_ARGS{PREREQ_PM} = {%{$MM_ARGS{PREREQ_PM}}, %{delete $MM_ARGS{BUILD_REQUIRES}}}
  if $eumm_version < 6.55_01;
WriteMakefile(%MM_ARGS);