1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
|
Source: libtree-redblack-perl
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Uploaders: gregor herrmann <gregoa@debian.org>,
Damyan Ivanov <dmn@debian.org>
Section: perl
Priority: optional
Build-Depends: debhelper (>= 10)
Build-Depends-Indep: perl
Standards-Version: 4.1.1
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-perl/packages/libtree-redblack-perl.git
Vcs-Git: https://anonscm.debian.org/git/pkg-perl/packages/libtree-redblack-perl.git
Homepage: https://metacpan.org/release/Tree-RedBlack
Testsuite: autopkgtest-pkg-perl
Rules-Requires-Root: no
Package: libtree-redblack-perl
Architecture: all
Depends: ${misc:Depends},
${perl:Depends}
Description: Perl implementation of Red/Black tree, a balanced tree
Tree::RedBlack is a demonstration package, showing the performance
differences between different methods of data storage and
accessing. It contains a perl implementation of the Red/Black tree
algorithm found in the book "Algorithms", by Cormen, Leiserson &
Rivest (more commonly known as "CLR" or "The White Book"). A
Red/Black tree is a binary tree which remains "balanced"- that is,
the longest length from root to a node is at most one more than the
shortest such length. It is fairly efficient; no operation takes
more than O(lg(n)) time.
.
An example perl script is contained in the documentation directory,
which would show the different run times using hash table, linear or
tree structure.
|