1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46
|
Source: libtree-simple-perl
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Uploaders: Niko Tyni <ntyni@iki.fi>,
gregor herrmann <gregoa@debian.org>,
Damyan Ivanov <dmn@debian.org>
Section: perl
Testsuite: autopkgtest-pkg-perl
Priority: optional
Build-Depends: debhelper-compat (= 13)
Build-Depends-Indep: libtest-exception-perl <!nocheck>,
libtest-memory-cycle-perl <!nocheck>,
libtest-simple-perl <!nocheck>,
perl
Standards-Version: 4.5.1
Vcs-Browser: https://salsa.debian.org/perl-team/modules/packages/libtree-simple-perl
Vcs-Git: https://salsa.debian.org/perl-team/modules/packages/libtree-simple-perl.git
Homepage: https://metacpan.org/release/Tree-Simple
Rules-Requires-Root: no
Package: libtree-simple-perl
Architecture: all
Depends: ${misc:Depends},
${perl:Depends}
Multi-Arch: foreign
Description: implementation of a simple tree object
Tree::Simple is a fully object-oriented implementation of a simple
n-ary tree. It is built upon the concept of parent-child
relationships, so therefore every Tree::Simple object has both a
parent and a set of children (who themselves may have children, and so
on). Every Tree::Simple object also has siblings, as they are just the
children of their immediate parent.
.
It can be used to model hierarchal information such as a file-system,
the organizational structure of a company, an object inheritance
hierarchy, versioned files from a version control system or even an
abstract syntax tree for use in a parser. It makes no assumptions as
to your intended usage, but instead simply provides the structure and
means of accessing and traversing said structure.
.
This module uses exceptions and a minimal Design By Contract
style. All method arguments are required unless specified in the
documentation, if a required argument is not defined an exception will
usually be thrown. Many arguments are also required to be of a
specific type, for instance the $parent argument to the constructor
must be a Tree::Simple object or an object derived from Tree::Simple,
otherwise an exception is thrown.
|