1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
|
From d8c6831c66b91d0db878ac247d607aa8daec4dcb Mon Sep 17 00:00:00 2001
From: Niko Tyni <ntyni@debian.org>
Date: Sat, 20 Mar 2010 23:31:17 +0200
Subject: [PATCH] Fix test failures on 64-bit architectures due to incompatible pointer types
Bug-Debian: https://bugs.debian.org/570670
Bug: https://rt.cpan.org/Public/Bug/Display.html?id=43404
Bug: https://rt.cpan.org/Public/Bug/Display.html?id=24652
Bug-RedHat: https://bugzilla.redhat.com/show_bug.cgi?id=182514
Map8.xs | 2 +-
map8.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Map8.xs b/Map8.xs
index 789f921..074ad99 100644
@@ -347,7 +347,7 @@ recode8(m1, m2, str)
Map8* m2
PREINIT:
STRLEN len;
- STRLEN rlen;
+ int rlen;
char* res;
INPUT:
char* str = SvPV(ST(2), len);
diff --git a/map8.h b/map8.h
index 007c5de..98dfb3b 100644
@@ -80,7 +80,7 @@ void map8_free(Map8*);
U16* map8_to_str16(Map8*, U8*, U16*, int, int*);
U8* map8_to_str8 (Map8*, U16*, U8*, int, int*);
-U8* map8_recode_8(Map8*, Map8*, U8*, U8*, int, int*);
+U8* map8_recode8(Map8*, Map8*, U8*, U8*, int, int*);
int map8_empty_block(Map8*, U8);
--
1.7.0
|