File: lws_config.h.in

package info (click to toggle)
libwebsockets 2.0.3-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 5,424 kB
  • ctags: 4,865
  • sloc: ansic: 33,281; perl: 1,656; sh: 872; cpp: 226; makefile: 77; awk: 5
file content (103 lines) | stat: -rw-r--r-- 2,904 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
/* lws_config.h  Generated from lws_config.h.in  */

#ifndef NDEBUG
	#ifndef _DEBUG
		#define _DEBUG
	#endif
#endif

/* Define to 1 to use wolfSSL/CyaSSL as a replacement for OpenSSL.
 * LWS_OPENSSL_SUPPORT needs to be set also for this to work. */
#cmakedefine USE_WOLFSSL

/* Also define to 1 (in addition to USE_WOLFSSL) when using the
  (older) CyaSSL library */
#cmakedefine USE_OLD_CYASSL

#cmakedefine LWS_USE_MBEDTLS
#cmakedefine LWS_USE_POLARSSL

#cmakedefine LWS_WITH_PLUGINS

/* The Libwebsocket version */
#cmakedefine LWS_LIBRARY_VERSION "${LWS_LIBRARY_VERSION}"

#define LWS_LIBRARY_VERSION_MAJOR ${LWS_LIBRARY_VERSION_MAJOR}
#define LWS_LIBRARY_VERSION_MINOR ${LWS_LIBRARY_VERSION_MINOR}
#define LWS_LIBRARY_VERSION_PATCH ${LWS_LIBRARY_VERSION_PATCH}
/* LWS_LIBRARY_VERSION_NUMBER looks like 1005001 for e.g. version 1.5.1 */
#define LWS_LIBRARY_VERSION_NUMBER (LWS_LIBRARY_VERSION_MAJOR*1000000)+(LWS_LIBRARY_VERSION_MINOR*1000)+LWS_LIBRARY_VERSION_PATCH

/* The current git commit hash that we're building from */
#cmakedefine LWS_BUILD_HASH "${LWS_BUILD_HASH}"

/* Build with OpenSSL support */
#cmakedefine LWS_OPENSSL_SUPPORT

/* The client should load and trust CA root certs it finds in the OS */
#cmakedefine LWS_SSL_CLIENT_USE_OS_CA_CERTS

/* Sets the path where the client certs should be installed. */
#cmakedefine LWS_OPENSSL_CLIENT_CERTS "${LWS_OPENSSL_CLIENT_CERTS}"

/* Turn off websocket extensions */
#cmakedefine LWS_NO_EXTENSIONS

/* Enable libev io loop */
#cmakedefine LWS_USE_LIBEV

/* Enable libuv io loop */
#cmakedefine LWS_USE_LIBUV

/* Build with support for ipv6 */
#cmakedefine LWS_USE_IPV6

/* Build with support for UNIX domain socket */
#cmakedefine LWS_USE_UNIX_SOCK

/* Build with support for HTTP2 */
#cmakedefine LWS_USE_HTTP2

/* Turn on latency measuring code */
#cmakedefine LWS_LATENCY

/* Don't build the daemonizeation api */
#cmakedefine LWS_NO_DAEMONIZE

/* Build without server support */
#cmakedefine LWS_NO_SERVER

/* Build without client support */
#cmakedefine LWS_NO_CLIENT

/* If we should compile with MinGW support */
#cmakedefine LWS_MINGW_SUPPORT

/* Use the BSD getifaddrs that comes with libwebsocket, for uclibc support */
#cmakedefine LWS_BUILTIN_GETIFADDRS

/* use SHA1() not internal libwebsockets_SHA1 */
#cmakedefine LWS_SHA1_USE_OPENSSL_NAME

/* SSL server using ECDH certificate */
#cmakedefine LWS_SSL_SERVER_WITH_ECDH_CERT
#cmakedefine LWS_HAVE_SSL_CTX_set1_param
#cmakedefine LWS_HAVE_X509_VERIFY_PARAM_set1_host

/* CGI apis */
#cmakedefine LWS_WITH_CGI

/* whether the Openssl is recent enough, and / or built with, ecdh */
#cmakedefine LWS_HAVE_OPENSSL_ECDH_H

/* HTTP Proxy support */
#cmakedefine LWS_WITH_HTTP_PROXY

/* Http access log support */
#cmakedefine LWS_WITH_ACCESS_LOG
#cmakedefine LWS_WITH_SERVER_STATUS

/* Maximum supported service threads */
#define LWS_MAX_SMP ${LWS_MAX_SMP}

${LWS_SIZEOFPTR_CODE}