1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
|
Remove code making call to getenv. We hardcode the path to the lib data.
--- a/LibApplications/Wm5Application.cpp
+++ b/LibApplications/Wm5Application.cpp
@@ -40,7 +40,10 @@
// WM5_PATH environment variable in order for the applications to find
// various data files.
#ifndef __APPLE__
- Application::WM5Path = Environment::GetVariable("WM5_PATH");
+ // Debian packaging modifs by FR <lopippo@debian.org>.
+ // We do not want to handle paths with environment variables.
+ // Application::WM5Path = Environment::GetVariable("WM5_PATH");
+ Application::WM5Path = "/usr/share/libwildmagic/";
#else
// Mac OS X Lion returns NULL on any getenv call (such as the one in
// Environment::GetVariable). This hack works around the problem.
|