File: changelog

package info (click to toggle)
libxkbcommon 0.7.1-2~deb9u1
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 5,652 kB
  • sloc: ansic: 29,370; sh: 4,413; yacc: 673; makefile: 302; python: 37
file content (180 lines) | stat: -rw-r--r-- 6,305 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
libxkbcommon (0.7.1-2~deb9u1) stretch; urgency=medium

  * Non-maintainer upload.
  * Rebuild for stretch.

 -- Andreas Beckmann <anbe@debian.org>  Mon, 27 Nov 2017 17:50:43 +0100

libxkbcommon (0.7.1-2) unstable; urgency=medium

  * Remove Cyril from Uploaders.
  * Add missing dependency libxkbcommon-x11-dev → libxkbcommon-dev
    (closes: #872874).

 -- Julien Cristau <jcristau@debian.org>  Sat, 16 Sep 2017 13:40:36 +0200

libxkbcommon (0.7.1-1) unstable; urgency=medium

  * New upstream release.
  * No need to explicitly enable --parallel, it's the default in compat 10.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Wed, 18 Jan 2017 20:05:33 +0100

libxkbcommon (0.7.0-1) unstable; urgency=medium

  * New upstream release.
  * debian/libxkbcommon0.symbols: add new symbols.
  * Build-depend on graphviz, needed for the doxygen docs. Closes: #844711.
  * Bump Standards-Version to 3.9.8, no changes.
  * Bump debhelper compat to 10.
    + debhelper now enables dh-autoreconf by default.
  * Stop passing --disable-silent-rules to configure, debhelper does that
    for a while.
  * debian/control: Update upstream git repo URL.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Wed, 07 Dec 2016 18:48:48 +0100

libxkbcommon (0.6.1-1) unstable; urgency=medium

  * New upstream release. (Closes: #815867)
  * Use secure URIs in Vcs-* tags

 -- Michael Stapelberg <stapelberg@debian.org>  Mon, 22 Aug 2016 09:14:43 +0200

libxkbcommon (0.5.0-1) unstable; urgency=medium

  * New upstream release.
  * Drop debian/patches, applied upstream.
  * libxkbcommon-dev: install documentation (Thanks Fernando Seiti Furusato)
    (Closes: #723086)
  * Enable --parallel (Thanks Pino Toscano) (Closes: #760621)

 -- Michael Stapelberg <stapelberg@debian.org>  Mon, 18 May 2015 19:53:18 +0200

libxkbcommon (0.4.3-2) unstable; urgency=high

  * d/p/0001-Remove-linux-input.h-include-from-test-x11comp.c.patch:
    + Patch from Pino Toscano to fix the build on !linux. Closes: #760624.
  * debian/control,
    debian/rules:
    + Enable quilt as the patch system.
  * High urgency for RC bug fix.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Tue, 16 Sep 2014 23:07:00 +0200

libxkbcommon (0.4.3-1) unstable; urgency=medium

  [ Andreas Henriksson ]
  * New upstream release (Closes: #750129).
  * Add build-dependencies used by new "x11comp" test:
    + x11-xkb-utils
    + xvfb
    (The test is supposed to skipped when these are not available,
    but actually it freezes.)

  [ Emilio Pozuelo Monfort ]
  * Upload to unstable.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Fri, 05 Sep 2014 02:40:43 +0200

libxkbcommon (0.4.1-2) unstable; urgency=medium

  * Make libxkbcommon-x11 depend on the same version of libxkbcommon0
    (Closes: #755724)

 -- Michael Stapelberg <stapelberg@debian.org>  Wed, 23 Jul 2014 08:35:57 +0200

libxkbcommon (0.4.1-1) unstable; urgency=medium

  [ Timo Aaltonen ]
  * New upstream release.
  * libxkbcommon0.symbols: Added three new symbols.

  [ Michael Stapelberg ]
  * Make libxkbcommon-x11-dev depend on libxcb1-dev and libxcb-xkb-dev which
    it specifies in Requires.private. This is necessary for static builds.

 -- Michael Stapelberg <stapelberg@debian.org>  Fri, 18 Jul 2014 21:16:31 +0200

libxkbcommon (0.4.0-1) unstable; urgency=low

  * New upstream release. This introduces the new binary packages
    libxkbcommon-x11-{0,dev} (Closes: #737391)
  * Canonicalize Vcs-*
  * Bump standards-version to 3.9.5 (no changes necessary)

 -- Michael Stapelberg <stapelberg@debian.org>  Sun, 09 Feb 2014 18:34:46 +0100

libxkbcommon (0.3.1-2) unstable; urgency=low

  * Cherry-pick ec9a02 from upstream, fixes FTBFS on hurd. Closes: #717723.
  * Re-enable the test suite on !linux. Thanks Pino Toscano. Closes: #715560.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Tue, 10 Sep 2013 01:45:53 +0200

libxkbcommon (0.3.1-1) unstable; urgency=low

  * Team upload.

  [ Timo Aaltonen ]
  * New upstream release 0.2.0. (Closes: #691699)
  * libxkbcommon-dev.install: Add new headers, rename existing.
  * control: Update Standards-Version, no changes.
  * watch: Updated.
  * control: Remove the comments about the experimental status, this is
    an actual release.
  * control: Use debhelper 9 and convert to multiarch.
  * control: Update the descriptions.
  * rules: Don't hardcode shlibs to the package version, this is an actual
    release now.
  * Use source format 1.0.
  * Add libxkbcommon0.symbols.
  * copyright: Remove the note about no tarballs, add upstream url.
  * control: Added homepage.
  * rules: Replace old tarball target with generic gentarball target.
  * rules: Don't run tests on !linux.

  [ Emilio Pozuelo Monfort ]
  * debian/watch:
    + Look for .xz tarballs.
  * New upstream release 0.3.1.
  * debian/libxkbcommon0.symbols:
    + Add Build-Depends-Package field.
    + Add new symbols.
  * debian/rules:
    + Pass -c4 to dpkg-gensymbols to abort the build if there are any
      new or missing symbols.
    + Make the build verbose.

 -- Emilio Pozuelo Monfort <pochu@debian.org>  Sun, 09 Jun 2013 01:50:50 +0200

libxkbcommon (0.1.0~1-1) experimental; urgency=low

  [ Cyril Brulebois ]
  * Fix short description for libxkbcommon-dev.

  [ Timo Aaltonen ]
  * Merge master up to c19661b965.

 -- Cyril Brulebois <kibi@debian.org>  Fri, 10 Feb 2012 22:12:02 +0100

libxkbcommon (0.1.0~0-1) experimental; urgency=low

  * Initial release (Closes: #611401):
    - Merge master up to b9b0011994.
  * Since there's no upstream release yet, use 0.1.0~X-Y as version
    numbers, with:
    - 0.1.0: the version currently in configure.ac;
    - X: an integer bumped everytime we create a snapshot;
    - Y: Debian revision.
  * Keep shlibs very strict: packages linking against libxkbcommon will
    pick a dependency on the particular revision they were linked
    against. Since users are likely to be only XServer and Wayland, that
    shouldn't be too much of a hassle. (All of them will probably stay in
    experimental for a while anyway, libxkbcommon support isn't merged in
    XServer's master yet.)
  * Write a “tarball” target to generate upstream tarballs for next
    snapshots.
  * Use xkb-data build-dep since it's needed for the test suite.

 -- Cyril Brulebois <kibi@debian.org>  Mon, 31 Jan 2011 05:07:13 +0100