1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59
|
PACKAGE=`pwd | sed -e "s/.*\/\\(.*\\)-.*/\\1/"`
build-arch: build
build-indep: build
build:
dh_testdir
perl Makefile.PL verbose INSTALLDIRS=vendor
-find $(CURDIR)/examples -name "*.rdf" -exec chmod -x {} \;
-chmod -x README
clean:
dh_testdir
dh_testroot
-$(MAKE) clean
rm -f Makefile.old
dh_clean
install:
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
$(MAKE) DESTDIR=$(CURDIR)/debian/$(PACKAGE) OPTIMIZE="-O2 -g -Wall" test install
-find $(CURDIR)/debian -type d | xargs rmdir -p --ignore-fail-on-non-empty
binary-arch:;
binary-indep: build install
dh_testdir
dh_testroot
dh_installdocs
dh_installexamples
dh_installman
dh_installchangelogs Changes
dh_link
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_perl
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build-indep build-arch build clean binary-indep binary-arch binary install configure
|