1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56
|
Description: Add exceptions for Unicode 13.
Author: Nicolas Boulenguez <nicolas@debian.org>
Forwarded: https://github.com/AdaCore/xmlada/pull/4
@@ -102,6 +102,7 @@
-- Uniquify names only differing only by a dash.
Add ("TIBETAN LETTER -A", "Tibetan_Letter_Dash_A");
Add ("TIBETAN SUBJOINED LETTER -A", "Tibetan_Subjoined_Letter_Dash_A");
+ Add ("MARCHEN LETTER -A", "Marchen_Letter_Dash_A");
end Set_Exceptions;
end Translators.Alias;
@@ -164,6 +164,18 @@
"Phags_Pa");
Add ("CJK Compatibility Forms",
"Cjk_Compatibility_Forms");
+
+ -- Unicode 9.
+ Add ("Ideographic Symbols and Punctuation",
+ "Ideograph_Symb_Punct");
+ -- Unicode 12.
+ Add ("Egyptian Hieroglyph Format Controls",
+ "Egypt_Hieroglyph_Fmt_Ctrl");
+ Add ("Symbols and Pictographs Extended-A",
+ "Symbols_Pictographs_Ext_A");
+ -- Unicode 13
+ Add ("Symbols for Legacy Computing",
+ "Symbols_Legacy_Computing");
end Set_Exceptions;
end Translators.Block;
@@ -1,4 +1,6 @@
MAIN := convert
+UNICODE_VERSION := 13.0.0
+UNICODE_URL := ftp://ftp.unicode.org/Public/$(UNICODE_VERSION)/ucd
UNICODE_FILES := Blocks.txt NameAliases.txt UnicodeData.txt
.PHONY: all clean ${MAIN}
@@ -11,9 +13,9 @@
gprbuild -p -Pconvert
$(filter-out NameAliases.txt,$(UNICODE_FILES)):
- wget ftp://ftp.unicode.org/Public/8.0.0/ucd/$@
+ wget $(UNICODE_URL)/$@
NameAliases.txt:
- wget ftp://ftp.unicode.org/Public/8.0.0/ucd/$@
+ wget $(UNICODE_URL)/$@
patch -p0 < NameAliases.diff
clean:
|