1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97
|
PACKAGE = libxss1
include debian/xsfbs/xsfbs.mk
CFLAGS = -Wall -g
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
CFLAGS += -O2
endif
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
MAKEFLAGS += -j$(NUMJOBS)
endif
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
confflags += --build=$(DEB_HOST_GNU_TYPE)
else
confflags += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
endif
build: build-stamp
build-stamp: $(STAMP_DIR)/patch
dh_testdir
autoreconf -vfi
mkdir -p build
cd build && \
../configure --prefix=/usr --mandir=\$${prefix}/share/man \
--libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
--infodir=\$${prefix}/share/info $(confflags) \
CFLAGS="$(CFLAGS)"
cd build && $(MAKE)
>$@
clean: xsfclean
dh_testdir
rm -f build-stamp
rm -f config.cache config.log config.status
rm -f */config.cache */config.log */config.status
rm -f conftest* */conftest*
rm -rf autom4te.cache */autom4te.cache
rm -rf build
rm -f aclocal.m4 config.guess config.h.in config.sub configure
rm -f depcomp install-sh ltmain.sh missing mkinstalldirs
find -name Makefile.in -delete
rm -f INSTALL
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
cd build && $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
binary-arch: build install
dh_testdir
dh_testroot
dh_installdocs
dh_install --sourcedir=debian/tmp --fail-missing --exclude=libXss.la --exclude=usr/share/man/man3
dh_installman
dh_installchangelogs ChangeLog
dh_link
dh_strip --dbg-package=$(PACKAGE)-dbg
dh_compress
dh_fixperms
dh_makeshlibs
dh_shlibdeps
dh_installdeb
dh_gencontrol
dh_md5sums
dh_builddeb
binary-indep: build install
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
|