1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
|
BUILDDIR = $(CURDIR)/debian/build
%:
dh $@ --buildsystem=cmake --builddirectory=$(BUILDDIR)
export OMPI_MCA_plm_rsh_agent=/bin/false
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
disable_auto_test_archs_simpl = armel armhf mips64el
disable_auto_test_archs_mpi = hurd-i386 mips mipsel mips64el s390 s390x powerpc
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
ifeq (,$(filter $(DEB_HOST_ARCH),$(disable_auto_test_archs_mpi)))
mkdir test
cp -r examples/LIGGGHTS/Tutorials_public/heatTransfer_1/* test/
cd test; mpirun -np 2 --allow-run-as-root --oversubscribe $(BUILDDIR)/src/liggghts < in.heatGran
rm -rf test
endif
ifeq (,$(filter $(DEB_HOST_ARCH),$(disable_auto_test_archs_simpl)))
mkdir test
cp -r examples/LIGGGHTS/Tutorials_public/heatTransfer_1/* test/
cd test; $(BUILDDIR)/src/liggghts < in.heatGran
rm -rf test
endif
endif
override_dh_installexamples:
dh_installexamples
find $(CURDIR)/debian/ -name ".gitignore" | xargs rm -f
|