File: changelog

package info (click to toggle)
lmodern 2.004.2-1
  • links: PTS, VCS
  • area: main
  • in suites: wheezy
  • size: 46,284 kB
  • sloc: sh: 204; makefile: 155
file content (518 lines) | stat: -rw-r--r-- 20,599 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
lmodern (2.004.2-1) unstable; urgency=low

  * ship lmmath-regular.otf font that was added to the TeX Live
    distribution and is necessary for the default math font setup
    of unicode-math (Closes: #684157)

 -- Norbert Preining <preining@debian.org>  Wed, 08 Aug 2012 01:02:48 +0900

lmodern (2.004.1-5) unstable; urgency=low

  * upload to unstable

 -- Norbert Preining <preining@debian.org>  Thu, 22 Mar 2012 18:22:17 +0900

lmodern (2.004.1-4) experimental; urgency=low

  [ Hilmar Preuße ]
  * Use maintscript support in dh_installdeb rather than writing out
    dpkg-maintscript-helper commands by hand. Thanks to Colin Watson
    (Closes: #659608)

  [ Norbert Preining ]
  * fix maintscript to use the right version number for removing
    defoma config file
  * tex-common v3 build for TL2012, bump build-deps
  * bump standards version to 3.9.3, no changes needed

 -- Norbert Preining <preining@debian.org>  Mon, 05 Mar 2012 09:47:26 +0900

lmodern (2.004.1-3.1) unstable; urgency=low

  * Non-maintainer upload
  * Transition away from defoma. Closes: #649831

 -- Christian Perrier <bubulle@debian.org>  Sat, 17 Dec 2011 19:05:45 +0100

lmodern (2.004.1-3) unstable; urgency=low

  * upload to unstable

 -- Norbert Preining <preining@debian.org>  Wed, 09 Dec 2009 23:49:18 +0900

lmodern (2.004.1-2) experimental; urgency=low

  * dummy reupload to get a working build due to defoma bug

 -- Norbert Preining <preining@debian.org>  Thu, 03 Dec 2009 23:22:19 +0900

lmodern (2.004.1-1) experimental; urgency=low

  * use section fonts instead of tex
  * new upstream release without version number change, fixed some .fd files

 -- Norbert Preining <preining@debian.org>  Tue, 17 Nov 2009 19:57:45 +0900

lmodern (2.004-1) experimental; urgency=low

  * change section to "fonts"
  * new upstream version(s) (Closes: #469437)
  * this release changes font names and mappings, many things might break
  * debian packaging changes:
    - bump standards version to 3.8.3
    - bump dephelper compat to 7
    - conflict with context (<= 2008.10.31-1) since that still ships the
      patch for old lmodern font names

 -- Norbert Preining <preining@debian.org>  Sun, 11 Oct 2009 15:00:34 +0900

lmodern (1.010x-5) unstable; urgency=medium

  * add Vcs-Svn and Vcs-Browser fields to debian/control [preining]
  * Bump build-depends on tex-common to version 1.11 (closes: #466036, a
    serious bug, hence medium urgency).
  * bump standards version to 3.7.3, no changes necessary
  * move the homepage into its own field in debian/control

 -- Norbert Preining <preining@debian.org>  Fri, 18 Apr 2008 07:48:46 +0200

lmodern (1.010x-4) unstable; urgency=low

  * Update the location of the original download in the copyright file
    (Closes: #421998). [preining]

  * Use dpkg-query in lmodern.preinst instead of parsing
    /var/lib/dpkg/status ourselves. [frn]

  * rehash /usr/share/texmf-texlive since we do not depend on texlive-base-bin
    (Closes: #441526)

 -- Norbert Preining <preining@debian.org>  Sat, 15 Sep 2007 11:26:46 +0200

lmodern (1.010x-3) unstable; urgency=low

  * Rebuild with tex-common 1.7 (closes: #419108).

 -- Florent Rougon <frn@debian.org>  Mon, 16 Apr 2007 13:35:40 +0200

lmodern (1.010x-2) unstable; urgency=low

  * Upload to unstable, no changes to the package.

 -- Norbert Preining <preining@debian.org>  Fri, 13 Apr 2007 08:43:51 +0200

lmodern (1.010x-1) experimental; urgency=low

  * New upstream release (only changes the OTF files).

  * Install the OpenType font files, as they are useful with XeTeX (cf.
    http://lists.debian.org/debian-tex-maint/2007/03/msg00313.html).

  * lmodern.cfg.in: comment out cork-lm.map, since it's only useful for
    compatibility with old DVI files, and these should now be rebuilt with
    the new font names.
    The next step will be to remove the backward-compatibility links
    (cork-lm.enc -> lm-ec.enc and similar, from compat.links). We
    don't do it yet, otherwise even uncommenting cork-lm.map from
    10lmodern.cfg won't be enough to work with old DVI files.

  * Symlink the useful documentation files from /usr/share/doc/texmf/fonts/lm/
    to /usr/share/doc/lmodern/, instead of copying them. Add new lm-hist.txt
    and lm-info.pdf to these files.

  * Don't Build-Depend on recode anymore, since its use was removed in 1.01-1.

  * Update debian/copyright.in.

  * debian.control: add home page and mention the OpenType format in the
    description.

  * lmodern.README.Debian: mention the OpenType format.

  * debian/rules: ignore empty lines when comparing the monolithic lm.map
    with the concatenation of the encoding-specific map files.

  * debian/rules: don't compress PDF files.

  * Add the build-arch target to debian/rules (cf.
    http://lists.debian.org/debian-mentors/2006/12/msg00267.html).

  * Add debian/TODO.

  * Shut up lintian about /usr/share/doc/texmf/fonts/lm/GUST-FONT-LICENSE.txt.
    Policy §12.5 says *nothing* about such files, and I think it's right to
    leave it there, as upstream wanted it.

 -- Florent Rougon <frn@debian.org>  Sun, 25 Mar 2007 11:12:35 +0200

lmodern (1.01-1) experimental; urgency=low

  * new upstream release
  * adding my Debian email adress to the Uploaders field
  * upload to experimental to not infere with the release of etch
  * add dependency on tex-common >= 1.1 to get a working dh_installtex
    --priority option

 -- Norbert Preining <preining@debian.org>  Sun, 25 Feb 2007 18:28:46 +0100

lmodern (1.00-3) unstable; urgency=low

  * Updated Maintainer field to use new mailing list [jdg]
  
 -- Julian Gilbey <jdg@debian.org>  Sun, 16 Jul 2006 21:37:46 +0100

lmodern (1.00-2) unstable; urgency=low

  * debian/lmodern.defoma-hints: don't inherit the FontName property,
    since it is redefined for each charset supported by the fonts.

 -- Florent Rougon <frn@debian.org>  Sun, 18 Jun 2006 21:15:45 +0200

lmodern (1.00-1) unstable; urgency=low

  * New upstream release.

    There are a bunch of new fonts. The new text fonts are lmdunh10, lmduno10,
    lmssq8, lmssqbo8, lmssqbx8, lmssqo8 and lmu10.

    The other new fonts are maths and symbol fonts. We don't register them
    with defoma, because:

      a) these fonts don't fit well in the defoma classification
         (GeneralFamily, Shape...);

      b) that doesn't look very useful (they support only a small part of
         ASCII, if any, so using them in applications such as text editors
         cannot be done without resorting to functions such as
         "Insert Special Characters"). OK, that might be useful for
         GhostScript... Since probably nobody uses that, I'd rather not bother
         unless specifically asked for this feature (having the maths/symbol
         fonts directly registered with GhostScript).

    The link to the Latin Modern wishlist web page in the upstream README
    file is now fixed (closes: #352949).

  * Use debian/copyright.in instead of debian/copyright.Debian (because
    the latter is confusing to me) and update it with the information
    shipped in LM 1.00.

  * The monolithic lm.map is incomplete in LM 1.00, therefore we use the
    more specific map files (lm-ec.map, etc.). They are found and declared
    automatically in 10lmodern.cfg. In order to do this,
    debian/lmodern.cfg is now generated from debian/lmodern.cfg.in, where
    '@LMODERN_BASIC_MAP_DECLARATIONS@' is simply replaced by the basic map
    declarations (where "basic" means those that should be equivalent to
    lm.map if it wasn't incomplete; not lm-rep-*.map, nor the cork-lm.map
    that we have for backward compatibility). This replacement is
    performed by two simple sed scripts: sed_scripts/extract-start and
    sed_scripts/extract-end.

  * Install a lintian override file for the inappropriate warning:

      lmodern: maintainer-script-needs-depends-on-ucf preinst

  * Use the "core X11 fonts system" expression in the package description
    and README.Debian (this is the one used in hw/xfree86/doc/README.fonts
    from the xorg-server 1.0.2 source package). Also, slightly update/trim
    these places about how fonts are rendered, because I think that with
    current X.Org, it is FreeType who does the rendering of Type 1 fonts,
    even when the core X11 fonts system is in use (although there is no
    antialiasing in this case, don't ask me why).

  * Use a build-indep-stamp file to avoid running the build-indep target
    twice per build (first time when "debian/rules build" is called,
    second time when "debian/rules binary" is invoked).

  * Recode MANIFEST.txt to have Unix-style line endings before installing
    it in /usr/share/doc/lmodern/. Add 'recode' to Build-Depends-Indep for
    this reason.

 -- Florent Rougon <frn@debian.org>  Sun, 18 Jun 2006 20:00:12 +0200

lmodern (0.99.3-4) unstable; urgency=low

  * lmodern.scale is back to /etc/X11/fonts/Type1/ because the location
    /etc/X11/fonts/X11R7 is deprecated (see debhelper's changelog for
    version 5.0.35 and bugs #366234 and #364530).
  * Build-Depend on debhelper (>= 5.0.35) because it seems to be needed by
    the aforementioned change.
  * Bump Standards-Version to 3.7.2 (the needed changes were already
    implemented in 0.99.3-3).

 -- Florent Rougon <frn@debian.org>  Sat, 27 May 2006 20:02:44 +0200

lmodern (0.99.3-3) unstable; urgency=low

  * Transition from XFree86 to X.org (Closes: #362330):
    - adapt the sed script gen-x-fonts-links-list to use
      /usr/share/fonts/X11/Type1
    - change the dh_installdirs line in rules
    - modify the README file for new location, and change to X.org.
    - build-dependency on debhelper >= 5.0.31, compat level set to 5
    - install .scale file to /etc/X11/fonts/X11R7/Type1, adapt the 
      dh_installdirs call.

 -- Norbert Preining <preining@logic.at>  Tue, 18 Apr 2006 17:18:00 +0200

lmodern (0.99.3-2) unstable; urgency=low

  * Use dh_installtex in debian/rules and Build-depend on tex-common
    (>= 0.16) for this reason.

 -- Florent Rougon <frn@debian.org>  Wed, 22 Feb 2006 17:10:15 +0100

lmodern (0.99.3-1) unstable; urgency=low

  * New Maintainer (Closes: #335899).

  * New upstream release (Closes: #298194).

  * Move map files to TEXMFMAIN [preining]

  * Switch to dh_installtexfonts for map/cfg file installation [preining]

  * Add compatibility for lmodern < 0.93 [ralf]
      - cork-lm.map adapted lm.map
      - cork-lm.enc -> lm-ec.enc

  * Add some explanation to README.Debian on textcomp (Closes: #348906)
    [ralf]

  * Change preinst logic for clean upgrades from sarge. [preining]

  * Add a NEWS.Debian explaining the changes to font names. [ralf, preining]
  
  * Add create-compat-links.sh to source package (not used anywhere; can be
    suggested to the admin in etch+1...) [ralf, preining]

 -- Florent Rougon <frn@debian.org>  Sat, 11 Feb 2006 16:38:56 +0100

lmodern (0.92-11) unstable; urgency=low

  * Set the Maintainer field to "Debian QA Group <packages@qa.debian.org>"
    in debian/control in order to orphan the package.

 -- Florent Rougon <frn@debian.org>  Wed, 26 Oct 2005 17:21:33 +0200

lmodern (0.92-10) unstable; urgency=low

  * Get rid of /etc/texmf/dvips/lm.map.dpkg-new for people who installed
    lmodern 0.92-7 in the same apt run that was doing the teTeX 2 to
    teTeX 3 upgrade (see bug #334658).

 -- Florent Rougon <frn@debian.org>  Fri, 21 Oct 2005 16:07:18 +0200

lmodern (0.92-9) unstable; urgency=low

  * This version is designed to work with teTeX 3, which was just uploaded
    to unstable. This brings conformance to TDS 1.1, a better way of
    registering the fonts with updmap (actually, we now have to use
    updmap-sys instead of updmap) as well as a few other changes described
    below.

  * No 0.92-8 version was ever uploaded to unstable, but versions such as
    0.92-8+tetex3+7 were used for tests and may still be installed on the
    tester's machines, therefore we jump to 0.92-9 directly to be on the
    safe side.

  * Remove tetex-bin and tetex-base from the dependency list
    (closes: #290001); in postinst, mktexlsr and updmap-sys are run only
    if they are available (this is now documented as the recommended
    scheme in the Debian TeX Policy). We depend on tex-common instead,
    which is quite small and necessary for reasons explained in the Debian
    TeX Policy.

  * Replace the explicit dependency on xutils by ${misc:Depends} (the
    previous versioned dependency isn't justified anymore).

  * Replace "echo -n" by "printf" in /bin/sh scripts, as "echo -n" is not
    specified by POSIX.

  * Mention in README.Debian that using non-OT1-encoded fonts directly
    with TeX is not convenient.

  * Update the comments in 10lmodern.cfg.

  * Update the FSF address in debian/copright.

  * Bump Standards-Version to 3.6.2.

 -- Florent Rougon <frn@debian.org>  Wed, 19 Oct 2005 00:37:25 +0200

lmodern (0.92-7) unstable; urgency=low

  * Patch {t1,qx,ts1}lmtt.fd so that the interword space is not
    stretchable nor shrinkable, just as in cmtt. Without this patch, lmtt
    is not really monospaced, which considerably impacts its usefulness.
    Closes: #295368.

  * Document that in README.Debian plus a couple of cosmetic fixes.
  
  * Small fix to a comment in the default version of 10lmodern.cfg.

  * Do not call try_to_update_fontmaps specifically at purge time anymore:
    it is already called at removal time, which should be enough unless
    the user is trying really hard to break his system (removes the
    package, manually recreates /etc/texmf/updmap.d/10lmodern.cfg, updates
    the font maps for this new broken setup and purges the package,
    leaving the broken configuration). This change will significantly
    speed up purges of lmodern.

  * Add some code in lmodern.preinst to remove ucf-related stuff for
    people upgrading from experimental versions 0.92-{4,5,6}.

 -- Florent Rougon <frn@debian.org>  Thu, 24 Feb 2005 16:53:21 +0100

lmodern (0.92-3) unstable; urgency=high

  * Urgency is set to high because since the changes in tetex-bin
    2.0.2-17, installing lmodern after tetex-base and tetex-bin would most
    likely result in an unusable lmodern package (until the next updmap
    run updating the map files under /var/lib/texmf/dvips/config/).
  
  * Remove "--outputdir /etc/texmf/dvips" from the updmap calls in
    lmodern.postinst and lmodern.postrm since tetex-bin 2.0.2-17 and later
    really want the generated map files to sit under
    /var/lib/texmf/dvips/config/. Without this change, installing lmodern
    would not affect the map files under /var/lib/texmf/dvips/config/,
    which are precisely the ones that are looked for first by the relevant
    programs (such as Dvips and pdfTeX) in the recommended configuration
    for tetex-bin 2.0.2-17 and later.
  
  * Adapt the comments in 10lmodern.cfg to reflect the new location for
    the map files generated by the updmap from tetex-bin 2.0.2-17 and
    later.
  
  * Fix a thinko in a comment from lmodern.postinst.

 -- Florent Rougon <f.rougon@free.fr>  Fri,  3 Sep 2004 00:24:56 +0200

lmodern (0.92-2) unstable; urgency=low

  * Slight rework of the debian/copyright file:
      1. the licensing terms for the Computer Modern fonts in Type 1
         format on which the Latin Modern fonts are based are now
         mentioned in an appendix to avoid confusing the reader;
      2. new short section describing the licensing terms for the Debian
         packaging.

  * Make the long description a bit more precise when explaining the
    differences between lmodern and cm-super.

 -- Florent Rougon <f.rougon@free.fr>  Tue, 10 Aug 2004 21:29:14 +0200

lmodern (0.92-1) unstable; urgency=low

  * New upstream release. The changes in this release that I am aware of 
    are kerning corrections, as inferred from
    http://groups.google.com/groups?th=380066b6513c2537, which boils down
    to:
  
      I've just uploaded to dante:/incoming/lm.zip 
      it contains ver. 0.92 of LM fonts (corrected and added kerning)  

    and a fix to AFM files (they used to contain an invalid keyword,
    "Generated", that is now properly embedded in a comment;
    closes: #243572).

 -- Florent Rougon <f.rougon@free.fr>  Fri, 23 Apr 2004 11:53:14 +0200

lmodern (0.86-9) unstable; urgency=low

  * Improved README.Debian with respect to using the fonts under the X
    Window System ("xset fp rehash", how to debug font path problems,
    etc.).
  
  * The lmodern-x11 package that was created in 0.86-8 doesn't exist any
    more. As of now, everything happens in the lmodern binary package,
    including registering of the fonts to the X Window System. Also,
    lmodern moves back to the 'tex' section.
  
    [ All this because when 0.86-8 was uploaded, it was blocked in NEW
      during more than ten days, after which it was REJECTED. With respect
      to the rejection, James Troup asked me why I had split the package,
      which I answered immediately, suggesting two alternatives and asking
      which one he preferred. My mail was never answered. ]
  
  * Little speed-up in debian/rules: dh_link is now called only once per
    build.
  
  * Minor fix in debian/rules: in case the upstream 0info086.txt is not
    found in the expected directory, building without this fix applied
    will cause an error message to be printed on stderr but won't stop.

  * The XLFD names for the fixed-width typewriter fonts were indicating a
    proportional spacing instead of "character cell". Fixed.

 -- Florent Rougon <f.rougon@free.fr>  Sun,  7 Mar 2004 18:43:35 +0100

lmodern (0.86-8) unstable; urgency=low

  * Updated lmodern.README.Debian with information on how to use the
    fonts with TeX-related programs, defoma-aware applications and X11.

  * lmodern-x11 explicitely depends on:
      - lmodern (>= 0.86-6) because this is the first version of the
        official Debian lmodern package (it might be that lmodern-x11
        doesn't work with the lmodern package previously distributed by
        Michael Wiedmann);
      - xutils (>= 4.1.0-12) because this is what Branden Robinson
        suggested to the gsfonts-x11 maintainer in bug #112140 (the
        update-fonts-{alias,dir,scale} programs in previous versions
        of xutils were not good enough according to him).
    Note:
      ${misc:Depends} could be used to automatically get the xutils
      dependency, but according to dh_installxfonts(1), this would be
      xutils (>= 4.0.3), which is not recent enough.

  * The source package and the lmodern binary package are now in the
    'text' section (as is the case for gsfonts) and the new lmodern-x11
    binary package is in the 'x11' section (as for gsfonts-x11).

  * The dependency on defoma is (>= 0.5.0) because
    /usr/share/doc/defoma-doc/type1-multiple-encodings.txt says this was
    the first version to support multiple encodings for Type 1 fonts.

  * The build-dependency on defoma is (>= 0.7.0) because this was the
    first version to ship dh_installdefoma.

  * All the lm*10 fonts are now registered with defoma and made available
    to X (10 is the size that has the highest number of variants).
    Notes:
      - defoma registration only is not enough for X to see the fonts
        because X is currently not a defoma "client";
      - the X support is in a separate binary package so that the lmodern
        binary package doesn't have to depend on xutils (I think this is
        the reason why gsfonts and gsfonts-x11 are separate packages).

  * Added --quiet to the updmap calls in lmodern.postinst and
    lmodern.postrm.

 -- Florent Rougon <f.rougon@free.fr>  Sat,  7 Feb 2004 17:52:38 +0100

lmodern (0.86-7) unstable; urgency=low

  * Fixed a bug that would cause lmodern.postrm to fail if the following
    sequence of events happened: lmodern deconfigured, tetex-bin removed,
    lmodern removed or purged.
  
  * debian/rules clean tried to remove lmodern.preinst instead of
    debian/lmodern.preinst, causing the presence of a useless file
    (debian/lmodern.preinst) in the .diff.gz.

 -- Florent Rougon <f.rougon@free.fr>  Thu, 29 Jan 2004 19:35:06 +0100

lmodern (0.86-6) unstable; urgency=low

  * First release of this Debian package for the Latin Modern fonts.
    Version is -6 so that people using the former unofficial package
    provided by Michael Wiedmann on http://www.miwie.org/lm/ can upgrade
    smoothly to this package.

 -- Florent Rougon <f.rougon@free.fr>  Tue, 27 Jan 2004 20:12:21 +0100

# vim:set fileencoding=utf-8: #
# Local Variables:
# coding: utf-8
# mode: debian-changelog
# End: