File: changelog

package info (click to toggle)
loggerhead-breezy 1.20~bzr551+dfsg-1
  • links: PTS, VCS
  • area: main
  • in suites: sid
  • size: 1,016 kB
  • sloc: python: 4,577; sh: 114; makefile: 112
file content (266 lines) | stat: -rw-r--r-- 8,880 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
loggerhead-breezy (1.20~bzr551+dfsg-1) unstable; urgency=medium

  * Move files that conflict with loggerhead proper files to
    /usr/share/loggerhead-breezy. Closes: #914690
  * New upstream snapshot.

 -- Jelmer Vernooij <jelmer@debian.org>  Tue, 27 Nov 2018 20:45:11 +0000

loggerhead-breezy (1.20~bzr544+dfsg-1) unstable; urgency=medium

  * Fork loggerhead package, renaming it to "loggerhead-breezy".
    Closes: #911486
   + Merging in upstream snapshot from new upstream.
   + Move to Python 3.
   + Update various upstream references from "loggerhead" to
     "loggerhead-breezy".
   + Drop patch request-method: applied upstream.
   + Refresh patch port-to-yui3.5.
  * Use secure URI in debian/watch.
  * Trim trailing whitespace.
  * Use secure copyright file specification URI.
  * Bump standards version to 4.2.1 (no changes).
  * Add autokgtest test that runs the testsuite.

 -- Jelmer Vernooij <jelmer@debian.org>  Sat, 20 Oct 2018 17:40:15 +0000

loggerhead (1.19~bzr479+dfsg-2) unstable; urgency=medium

  [ Jelmer Vernooij ]
  * Use canonical URL in Vcs-Bzr header.
  * Re-add myself to uploaders.

  [ Vincent Ladeuil ]
  * Bump versionized dependency on bzr. Closes: #822653
  * Add myself to Uploaders.

  [ Jelmer Vernooij ]
  * Add patch request-method.patch: Support running tests with bzr-git
    plugin installed.
  * Bump standards version to 3.9.8 (no changes).

 -- Jelmer Vernooij <jelmer@debian.org>  Sun, 04 Sep 2016 15:04:28 +0000

loggerhead (1.19~bzr479+dfsg-1) unstable; urgency=medium

  [ Jelmer Vernooij ]
  * Remove myself from uploaders.

  [ Andrew Starr-Bochicchio ]
  * Use machine readable copyright format.
  * Add get-orig-source target that strips out the bundled
    copy of YUI3 and create a DFSG clean tarball (Closes: #737427).
    We already use the system copy anyways.
  * In debian/watch, use the dversionmangle option to remove the dfsg
    before version number comparison.
  * Bump Standards-Version to 3.9.5, no changes needed.
  * Add myself to Uploaders.
  * Run wrap-and-sort over debian/control.

 -- Andrew Starr-Bochicchio <asb@debian.org>  Tue, 11 Mar 2014 13:25:26 -0400

loggerhead (1.19~bzr479-3) unstable; urgency=low

  * Team upload.
  * debian/control: Mark as compatible with bzr 2.6. (Closes: #718729).

 -- Andrew Starr-Bochicchio <asb@debian.org>  Sun, 04 Aug 2013 17:03:32 -0400

loggerhead (1.19~bzr479-2) unstable; urgency=low

  * Updated Standards-Version to 3.9.3 (no changes).
  * Use packaged underscore.js rather than shipping an embedded copy.
  * Simpler way to filter static files out of the distutils installation.

 -- Roland Mas <lolando@debian.org>  Thu, 08 Nov 2012 21:17:30 +0100

Loggerhead (1.19~bzr479-1) unstable; urgency=low

  * Port to current YUI API, and use the packaged version rather than
    shipping an embedded copy (closes: #607447).  Thanks to Rick Harding
    for much help with the porting.
  * And let's grab the latest from upstream while we're at it.

 -- Roland Mas <lolando@debian.org>  Wed, 07 Nov 2012 17:12:43 +0100

loggerhead (1.19~bzr477-1) unstable; urgency=low

  * New upstream snapshot (actually, it's 1.18.2).
  * I guess I should step up as maintainer (closes: #668933).  Thanks,
    Jelmer!
  * Ship static files in their proper place.

 -- Roland Mas <lolando@debian.org>  Tue, 06 Nov 2012 22:49:45 +0100

loggerhead (1.19~bzr461-1) unstable; urgency=low

  * New upstream snapshot.
  * Add build-dependency on python-fixtures, required for running testsuite.

 -- Jelmer Vernooij <jelmer@debian.org>  Sat, 26 Nov 2011 18:50:21 +0100

loggerhead (1.18.1+bzr457-1) unstable; urgency=low

  * Mark as compatible with pre-releases of bzr 2.5.
  * New upstream snapshot.
  * Move local changes into debian/. Closes: #643204
  * Fix update-deps.py to not remove loggerhead-doc.

 -- Jelmer Vernooij <jelmer@debian.org>  Fri, 30 Sep 2011 10:20:06 +0200

loggerhead (1.18.1+bzr447-2) unstable; urgency=low

  [ Max Bowsher ]
  * Re-arrange | condition in build deps to make sbuild happy.

  [ Andrew Starr-Bochicchio ]
  * Add new loggerhead-doc package (Closes: #626335).
  * Bump Standards-Version to 3.9.2, no changes.

 -- Jelmer Vernooij <jelmer@debian.org>  Tue, 19 Jul 2011 21:20:08 +0200

loggerhead (1.18.1+bzr447-1) experimental; urgency=low

  * New upstream snapshot.

 -- Jelmer Vernooij <jelmer@debian.org>  Thu, 02 Jun 2011 14:11:55 +0200

loggerhead (1.18.1-3) unstable; urgency=low

  [ Max Bowsher ]
  * Re-arrange | condition in build deps to make sbuild happy. Closes: #629783

  [ Jelmer Vernooij ]
  * Depend on python-bzrlib rather than bzr.
  * Bump standards version to 3.9.2 (no changes).

 -- Jelmer Vernooij <jelmer@debian.org>  Thu, 09 Jun 2011 22:48:50 +0100

loggerhead (1.18.1-2) unstable; urgency=low

  * Add build dependency on python-bzrlib.tests, required for newer
    versions of bzr.

 -- Jelmer Vernooij <jelmer@debian.org>  Sun, 01 May 2011 02:55:06 +0200

loggerhead (1.18.1-1) unstable; urgency=high

  * Bump python-simplejson from Recommends to Depends, as loggerhead
    breaks with python-json. LP: #586611
  * Switch to dh_python2. Closes: #616876
  * Switch to debhelper 7, drop cdbs.
  * Claim support for Bazaar 2.4.
  * New upstream release.
   + Fixes escaping of filenames in revision views. (CVE-2011-0728)
     LP: #740142

 -- Jelmer Vernooij <jelmer@debian.org>  Fri, 25 Mar 2011 01:02:13 +0100

loggerhead (1.18-2) unstable; urgency=low

  * Run the test suite during package build.

 -- Jelmer Vernooij <jelmer@debian.org>  Sun, 27 Feb 2011 23:27:37 +0100

loggerhead (1.18-1) unstable; urgency=low

  [ Max Bowsher ]
  * New upstream release.
   + Depends on bzr >= 1.17. Closes: #605653
  * Remove remnants of patching to use the system YUI, which actually broke
    the use of YUI entirely. Loggerhead requires YUI 3, which is
    not packaged yet. Until it is, include YUI.

 -- Jelmer Vernooij <jelmer@debian.org>  Sat, 18 Dec 2010 14:43:23 +0100

loggerhead (1.17+bzr429-1) unstable; urgency=low

  [ Andrew Starr-Bochicchio ]
  * debian/control:
   - Recommend python-pygments to support syntax-highlighting. (LP: #607775)
   - Add Vcs-Browser field.
   - Bump Standards-Version to 3.9.1, no-changes needed.

  [ Jelmer Vernooij ]
  * New upstream snapshot.
  * Cope with bzrlib.util.configobj no longer existing.
  * Add convenience script for automatically updating dependencies.

 -- Jelmer Vernooij <jelmer@debian.org>  Mon, 11 Oct 2010 11:00:01 +0200

loggerhead (1.17+bzr424-1) unstable; urgency=low

  * Use source format version 3.
  * Bump standards version to 3.8.4
  * Use new upstream snapshot.
   + Fixes import issues when running full Bazaar testsuite.

 -- Jelmer Vernooij <jelmer@debian.org>  Mon, 08 Feb 2010 01:17:39 +0100

loggerhead (1.17+bzr400-1) unstable; urgency=low

  * New upstream snapshot.

 -- Jelmer Vernooij <jelmer@debian.org>  Mon, 18 Jan 2010 18:33:40 +1300

loggerhead (1.17-1) unstable; urgency=low

  * New upstream release.  Loggerhead no longer flattens branch
    hierarchies (closes: #507001).

  [ Roland Mas ]
  * Use the YUI library provided by libjs-yui. (Closes: #511286)
  * Switch init script to use serve-branches rather than
    start-loggerhead (closes: #511295).

  [ Jelmer Vernooij ]
  * Use my debian.org address in Uploaders field.
  * Add ${misc:Depends} to please lintian.
  * Suggest recent version of paste, which doesn't expose internal port
    numbers in links. (Closes: #507000)
  * Bump standards version to 3.8.3.

  [ James Westby ]
  * New upstream release.
  * Drop get-orig-source rule in favour of debian/watch.
  * Add python-pkg-resources and python-paste to Build-Depends,
    python-pkg-resources to Depends and python-simplejson to
    Recommends due to dependency changes.

  [ Jelmer Vernooij ]
  * Remove references to bzrlib installation from example config file.

  [ Roland Mas ]
  * Added myself to Uploaders.
  * Documented version discrepancy between the YUI shipped by libjs-yui
    and the one used by Loggerhead, as well as a workaround to be used
    until YUI 3 becomes available.

 -- Roland Mas <lolando@debian.org>  Tue, 29 Sep 2009 15:57:44 +0200

loggerhead (1.10-1) unstable; urgency=low

  * New upstream release.
  * Stop writing home directory to pid file. (Closes: #507002)
  * Use objlib from bzr. (Closes: #506999)
  * Fix dependency on python-paste.

 -- Jelmer Vernooij <jelmer@samba.org>  Tue, 09 Dec 2008 01:04:39 +0100

loggerhead (1.6+bzr245-1) unstable; urgency=low

  * New upstream snapshot.

 -- Jelmer Vernooij <jelmer@samba.org>  Fri, 21 Nov 2008 01:11:24 +0100

loggerhead (1.6+bzr241-1) unstable; urgency=low

  * New upstream snapshot.

 -- Jelmer Vernooij <jelmer@samba.org>  Fri, 07 Nov 2008 16:03:13 +0100

loggerhead (1.6-1) unstable; urgency=low

  * Initial release. (Closes: #492477)

 -- Jelmer Vernooij <jelmer@samba.org>  Fri, 25 Jul 2008 22:43:49 +0200