1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
|
Description: Fixes the compatibility with Java 9
Author: Emmanuel Bourg <ebourg@apache.org>
Forwarded: no
@@ -279,7 +279,7 @@
return true;
}
- public Enumeration<?> children() {
+ public Enumeration children() {
return Collections.enumeration(Collections.emptySet());
}
}
@@ -15,7 +15,7 @@
return false;
}
- public abstract Enumeration<?> children();
+ public abstract Enumeration children();
public abstract boolean getAllowsChildren();
public abstract TreeNode getChildAt(int childIndex);
public abstract int getChildCount();
|