File: remove_rubygems_usage

package info (click to toggle)
logol 1.7.0-2
  • links: PTS, VCS
  • area: main
  • in suites: jessie, jessie-kfreebsd
  • size: 4,660 kB
  • ctags: 1,144
  • sloc: java: 10,613; perl: 2,651; ansic: 362; xml: 322; ruby: 280; sh: 115; makefile: 35
file content (28 lines) | stat: -rw-r--r-- 1,260 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
Subject: Remove explicit use of rubygems
Description:  Supported version of Ruby in Jessie+ are higher that 1.9
 and they all automatically load rubygems
Author: C├ędric Boutillier <boutil@debian.org>
Last-Update: 2014-01-16

--- a/tools/logolIndex.rb
+++ b/tools/logolIndex.rb
@@ -1,5 +1,4 @@
 #!/usr/bin/env ruby
-require 'rubygems'
 require 'optparse'
 require 'logger'
 require 'cassiopee-mt'
--- a/tools/logolSearch.rb
+++ b/tools/logolSearch.rb
@@ -22,9 +22,9 @@
 DIR=File.expand_path(File.dirname(__FILE__))
 
 if muteOnly.to_i == 1
-  cmd = "ruby -rubygems "+DIR+"/logolIndex.rb --search "+sequence+".index --min "+minStart+" --max "+maxStart+" --pattern "+motifFileName+" --error "+nbError+" --hamming"
+  cmd = "ruby "+DIR+"/logolIndex.rb --search "+sequence+".index --min "+minStart+" --max "+maxStart+" --pattern "+motifFileName+" --error "+nbError+" --hamming"
 else
-  cmd = "ruby -rubygems "+DIR+"/logolIndex.rb --search "+sequence+".index --min "+minStart+" --max "+maxStart+" --pattern "+motifFileName+" --error "+nbError
+  cmd = "ruby "+DIR+"/logolIndex.rb --search "+sequence+".index --min "+minStart+" --max "+maxStart+" --pattern "+motifFileName+" --error "+nbError
 end
 
 Open3.popen3(cmd) do |stdin,stdout,stderr, wait_thr|