1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52
|
DEB_ANT_BUILD_TARGET=create-jar,test_swi
DEB_ANT_ARGS=-Dant.build.javac.source=1.5 -Dant.build.javac.target=1.5
%:
dh $@
override_dh_auto_build:
mv tools/pldoc.sty tools/pldoc.sty.upstream
dh_auto_build -- $(DEB_ANT_ARGS)
ant -f build.xml doc
override_dh_install:
dh_install
rm -f debian/logol/usr/share/logol/prolog/*.c
rm -f debian/logol/usr/share/logol/prolog/*.exe
rm -f debian/logol/usr/share/logol/prolog/logol.properties
rm -f debian/logol/usr/share/logol/tools/*.keep_old_script
if [ -e debian/logol ]; then chmod -f 755 debian/logol/usr/share/logol/*.sh; fi
if [ -e debian/logol ]; then chmod -f 755 debian/logol/usr/share/logol/tools/*.sh; fi
if [ -e debian/logol ]; then chmod -f 755 debian/logol/usr/share/logol/tools/*.rb; fi
if [ -e debian/logol ]; then chmod -f 755 debian/logol/usr/share/logol/tools/mycostfunction; fi
override_dh_clean:
if [ -e tools/pldoc.sty.upstream ]; then mv tools/pldoc.sty.upstream tools/pldoc.sty; fi
mkdir -p test/tmp
mkdir -p test/results
dh_clean
rm -f Swi*.xml
rm -f prolog/*.exe
rm -f lib/*.jar
rm -f *.log
rm -f src/org/irisa/genouest/logol/parser/*
rm -f tools/suffixSearch.sh
rm -rf test/tmp
rm -rf test/results
override_dh_installexamples:
rm -f test/tmp/*
rm -f test/results/*
dh_installexamples
override_dh_strip:
dh_strip -Xlogol.exe -Xpreanalyse.exe
get-orig-source:
debian/get-orig-source.sh
|