File: changelog

package info (click to toggle)
lombok 1.16.22-7
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 7,064 kB
  • sloc: java: 54,583; xml: 1,947; sh: 41; makefile: 20; ansic: 16
file content (178 lines) | stat: -rw-r--r-- 6,119 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
lombok (1.16.22-7) unstable; urgency=medium

  * Team upload.
  * Removed the build dependency on OpenJDK 8 (Closes: #920714)

 -- Emmanuel Bourg <ebourg@apache.org>  Tue, 05 Feb 2019 22:30:12 +0100

lombok (1.16.22-6) unstable; urgency=medium

  * Team upload.
  * Added the missing dependency on libeclipse-jdt-core-manipulation-java
    (Closes: #918552)
  * Standards-Version updated to 4.3.0

 -- Emmanuel Bourg <ebourg@apache.org>  Tue, 22 Jan 2019 16:46:16 +0100

lombok (1.16.22-5) unstable; urgency=medium

  * Team upload.
  * Build depend on libeclipse-jdt-ui-java instead of eclipse-jdt

 -- Emmanuel Bourg <ebourg@apache.org>  Fri, 23 Nov 2018 15:46:34 +0100

lombok (1.16.22-4) unstable; urgency=medium

  * Team upload.

  [ Emmanuel Bourg ]
  * Removed the now unused build dependency on eclipse-platform-data

  [ Markus Koschany ]
  * Add java11-log-error.patch and fix FTBFS with Java 11. (Closes: #910748)

 -- Markus Koschany <apo@debian.org>  Thu, 08 Nov 2018 14:16:26 +0100

lombok (1.16.22-3) unstable; urgency=medium

  * Team upload.
  * Update build.patch and ensure that -unpackLibs is executed during the
    compile step. Otherwise ASM and lombok-patcher classes will be missing from
    the resulting lombok.jar which makes lombok-ast FTBFS.
  * Add remove-j9stub.patch to fix a module error.

 -- Markus Koschany <apo@debian.org>  Thu, 04 Oct 2018 10:39:22 +0200

lombok (1.16.22-2) unstable; urgency=medium

  * Team upload.
  * Build delombok and other missing core classes
  * Refreshed the Maven poms

 -- Emmanuel Bourg <ebourg@apache.org>  Thu, 20 Sep 2018 01:32:40 +0200

lombok (1.16.22-1) unstable; urgency=medium

  * Team upload.

  [ Markus Koschany ]
  * Drop the liblombok-java-doc package
  * New upstream version 1.16.20+ds

  [ Emmanuel Bourg ]
  * New upstream release
    - Build with default-jdk but keep the dependency on OpenJDK 8
      to build part of the code (Closes: #893312)
    - Depend on ivyplusplus (>= 1.26)
    - Refreshed the patches
    - Disabled delombok (fails to build, never used in Debian)
    - Fixed the compatibility of PackageName.java with Java 9
    - Dropped support for Java 6 & 7
  * Removed the +ds suffix
  * Standards-Version updated to 4.2.1
  * Use salsa.debian.org Vcs-* URLs

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 19 Sep 2018 13:48:16 +0200

lombok (1.16.18+ds-3) unstable; urgency=medium

  * Team upload.
  * Switch to compat level 11.
  * Use https for Format field.
  * Declare compliance with Debian Policy 4.1.5.
  * Switch to OpenJDK 8 again and work around the FTBFS with later versions to
    buy more time for a proper fix. (Closes: #893312)
  * Build-depend on libosgi-core-java to fix a FTBFS.

 -- Markus Koschany <apo@debian.org>  Sun, 08 Jul 2018 22:55:43 +0200

lombok (1.16.18+ds-2) unstable; urgency=medium

  * Team upload.
  * Upload to unstable after testing r-deps.  (Closes: #872189)

 -- tony mancill <tmancill@debian.org>  Sat, 19 Aug 2017 15:34:06 -0700

lombok (1.16.18+ds-1) experimental; urgency=medium

  * Team upload.
  * New upstream release.
  * Refresh patches for new upstream version
  * Update debian/rules for new upstream version
  * Disable logic of non-javadoc targets in buildScripts/website.ant.xml
  * Use debhelper and compat level 10

 -- tony mancill <tmancill@debian.org>  Wed, 16 Aug 2017 21:45:33 -0700

lombok (1.16.8+ds-2) unstable; urgency=medium

  * Team upload.
  * Drop liblombok-java.jlibs and use maven-repo-helper to install
    jars into /usr/share/java and to reduce the duplication.
  * Declare compliance with Debian Policy 3.9.8.

 -- Markus Koschany <apo@debian.org>  Sat, 16 Apr 2016 11:00:10 +0200

lombok (1.16.8+ds-1) unstable; urgency=medium

  * Team upload.
  * Imported Upstream version 1.16.8+ds.
  * Switch B-D libasm4-java to libasm-java.
  * Remove B-D ivy.
  * Add new build-dependency libecj-java but do not include it in lombok.jar.
  * Update debian/copyright for new release. The GPL-2 licensed class is gone.
  * Ensure that lombok can be built twice in a row.

 -- Markus Koschany <apo@debian.org>  Sat, 02 Apr 2016 10:19:36 +0200

lombok (1.16.6+ds-3) unstable; urgency=medium

  * Team upload.
  * Make the build reproducible by adding addtionalparam="-notimestamp"
    back to the build.
  * Do not create lombok.version.properties file in debian directory.
  * Set lombok.version to 1.16.6 explicitly.

 -- Markus Koschany <apo@debian.org>  Mon, 14 Mar 2016 14:30:53 +0100

lombok (1.16.6+ds-2) unstable; urgency=medium

  * debian/rules: Remove maven-repo-helper.jar from runtime path and do not
    include those class files into lombok.jar.

 -- Markus Koschany <apo@debian.org>  Tue, 16 Feb 2016 13:45:17 +0100

lombok (1.16.6+ds-1) unstable; urgency=medium

  * Team upload.
  * Add javac.patch and fix compilation error with OpenJDK 8. (Closes: #814764)
  * Add build.patch. Use upstream's build.xml file but prevent the build system
    from downloading anything from the web.
  * Drop debian/build-xml.
  * Add javadoc.patch and fix compilation error when building the
    dcoumentation. Thus the -doc package will not be empty anymore.
  * Replace liblombok-java-doc.javadoc with liblombok-java-doc.install.
  * Remove debian/links file.
  * Fix debian/watch and do not use githubredir anymore. It is obsolete.
  * Simplify get-orig-source target and use Files-Excluded mechanism.
  * Repack the tarball and remove superfluous dll files.
  * Update the package description of liblombok-java because the package is
    complete now.
  * Add ivyplusplus and liblombok-patcher-java to Build-Depends.
  * Ensure that cmdreader, lombok-patcher and ASM are injected into lombok.jar.
  * Install maven artifacts into local maven-repo. Build with
    maven_repo_helper.

 -- Markus Koschany <apo@debian.org>  Mon, 15 Feb 2016 19:48:33 +0100

lombok (1.16.6-1) unstable; urgency=low

  * Initial release. (Closes: #807816)

 -- Hans-Christoph Steiner <hans@eds.org>  Sun, 13 Dec 2015 23:23:23 +0100

lombok (0.11.6-1) UNRELEASED; urgency=low

  * Initial work

 -- Jakub Adam <jakub.adam@ktknet.cz>  Fri, 02 Nov 2012 21:28:02 +0100