1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
|
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
%:
dh $@ --buildsystem=lua --with lua
override_dh_auto_clean:
-rm $(CURDIR)/src/errno.c $(CURDIR)/config.h $(CURDIR)/src/config.h $(CURDIR)/src/lib/config.h
dh_auto_clean
override_dh_auto_configure:
make -C . -f GNUmakefile $(CURDIR)/config.h
make -C src -f GNUmakefile $(CURDIR)/src/errno.c $(CURDIR)/src/config.h
make -C src/lib -f GNUmakefile $(CURDIR)/src/lib/config.h
dh_auto_configure
override_dh_compress:
dh_compress -X.lua -X.cnf
|