File: lua5.1.dh-lua.conf

package info (click to toggle)
lua-expat 1.3.0-2
  • links: PTS, VCS
  • area: main
  • in suites: jessie, jessie-kfreebsd
  • size: 224 kB
  • ctags: 131
  • sloc: ansic: 511; makefile: 29
file content (20 lines) | stat: -rw-r--r-- 602 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
PKG_NAME=expat

### things relative to the C library part
CLIB_CFLAGS= -I src/ $(shell pkg-config expat --cflags)
CLIB_LDFLAGS= $(shell pkg-config expat --libs)
CLIB_OBJS= src/lxplib.lo

### things relative to the lua library part
LUA_HEADER=src/lxplib.h
LUA_SOURCES=src/lxp/lom.lua
LUA_SOURCES_MANGLER=sed 's?^src/??'
LUA_MODNAME=lxp
LUA_TEST=tests/test.lua; tests/test-lom.lua

### this part is relative to pkg-config
PKG_VERSION=$(shell dpkg-parsechangelog|grep ^Ver|cut -d ' ' -f 2|cut -d '-' -f 1)
PKG_LIBS_PRIVATE=
PKG_URL=http://matthewwild.co.uk/projects/luaexpat/
PKG_REQUIRES=
PKG_CONFLICTS=