File: changelog

package info (click to toggle)
lxdoom 1.4.4main-0.1
  • links: PTS
  • area: main
  • in suites: etch, etch-m68k
  • size: 4,092 kB
  • ctags: 6,838
  • sloc: ansic: 53,874; sh: 1,944; asm: 650; makefile: 141
file content (198 lines) | stat: -rw-r--r-- 7,002 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
lxdoom (1.4.4main-0.1) unstable; urgency=high

  * Non-maintainer upload.
  * Rename source tarball to include it in main (Closes: #358073).

 -- Luk Claes <luk@debian.org>  Sun, 30 Apr 2006 00:19:54 +0200

lxdoom (1.4.4-10) unstable; urgency=low

  * Acknowledge NMUs. Thanks, everyone.
    (Closes: #274088, #297718, #347140, #279190, #269916)
  * Depend on debconf | debconf-2.0. (Closes: #332013)
  * Fix typos in boom.cfg manpage (Closes: #310021)
  * Remove URLs in lxdoom manpage - sadly, there seem to be no authoritative
    location for dosdoom or pwad files anymore. (Closes: Bug#275713)
  * Depend on freedoom | doom-wad | doom-wad-editor, only 2 years late.
    (Closes: Bug#270038)

 -- Joe Drew <drew@debian.org>  Mon, 27 Feb 2006 10:44:05 -0500

lxdoom (1.4.4-9.3) unstable; urgency=low

  * Non-maintainer upload.
  * Adjust Build-Depends for xlibs transition (Closes: #347140).

 -- Christoph Berg <myon@debian.org>  Fri, 20 Jan 2006 19:54:34 +0100

lxdoom (1.4.4-9.2) unstable; urgency=low

  * 0-day NMU during the BSP.
  * Added a patch by Andreas Jochen to fix the build with gcc-4.0 (closes:
    bug#274088, bug#297718).
  * debian/rules:
    - s/DEB_BUILD_GNU_CPU/DEB_BUILD_ARCH_CPU/g
    - s/DEB_BUILD_GNU_SYSTEM/DEB_BUILD_ARCH_OS/g
    - Added kfreebsd to the list of kernels that support sound.
    - Update config.{guess,sub} at build time.
  * debian/control:
    - Added build-dependency on autotools-dev
    - Added build-dependency on dpkg-dev (>= 1.13) for new DEB_* variables
      support.

 -- Aurelien Jarno <aurel32@debian.org>  Fri,  5 Aug 2005 10:06:48 +0200

lxdoom (1.4.4-9.1) unstable; urgency=high

  * Non-maintainer upload.
  * Including <errno.h> to build correctly. (closes: #279190)
  * lxdoom-x11 is now able to find supported vistual settings.
    (closes: #268924)

 -- Bruno Barrera C. <bruno@debian.org>  Mon, 23 May 2005 21:54:30 -0400

lxdoom (1.4.4-9) unstable; urgency=low

  * Move lxdoom to main (Closes: Bug#266197)
  * Build with correct manpage. I guess I uploaded a .deb without the
    changes before. Closes: Bug#186404 

 -- Joe Drew <drew@debian.org>  Wed, 25 Aug 2004 21:52:22 -0400

lxdoom (1.4.4-8) unstable; urgency=low

  * Remove debconf handling of suid bit/dpkg-statoverride. Time to get
    with the program and stop having ridiculous debconf use in my packages.
    Closes: Bug#237108
  * Change Depends: to lxdoom-x11 | lxdoom-svga so that -x11 is chosen
    by default when someone runs `apt-get install lxdoom'.
  * Integrate GNU/Hurd patch. Closes: Bug#148857
  * debian/rules:
     + Support more recent DEB_BUILD_OPTIONS
  * debian/control:
     + Update to Standards-Version 3.6.1
  * Fix lxdoom man page wrapping. Closes: Bug#186404 
  * Update menu files to be more syntax-compliant.

 -- Joe Drew <drew@debian.org>  Sat, 27 Mar 2004 00:17:56 -0500

lxdoom (1.4.4-7) unstable; urgency=low

  * debian/control:
      + Correct spelling error in lxdoom-sndserv description (Closes: #125101)
      + Correct reference to lxdoom-x11 from lxdoom-x (Closes: #128962)
      + Change Suggests to Recommends for lxdoom-sndserv and lxmusserv
        (Closes: #128359)
      + Upgrade to Standards-Version 3.5.6
      + Change Build-Depends on debhelper to >= 3.0.0, because of use
        of dh_installman
  * Wrote a manpage for sndserv.
  * debian/rules:
      + modify to support DEB_BUILD_OPTIONS
  * Switch to DH_COMPAT=3, and all that entails

 -- Joe Drew <drew@debian.org>  Sun, 13 Jan 2002 01:21:26 -0500

lxdoom (1.4.4-6) unstable; urgency=low

  * Tuned build-dependencies for i386 only
  * network and disk structure packing for arm (possibly others?)
    Gallantly provided by Tim Rikers <tim@rikers.org> I'm in your debt!

 -- Joe Drew <drew@debian.org>  Wed, 30 May 2001 22:28:56 -0400

lxdoom (1.4.4-5) unstable; urgency=low

  * Enabled build on multiple architectures (ignoring lxdoom-svga) 
    Closes: Bug#85850

 -- Joe Drew <drew@debian.org>  Tue, 13 Feb 2001 22:10:52 -0500

lxdoom (1.4.4-4) unstable; urgency=low

  * Fixed stupid template paste error 

 -- Joe Drew <drew@debian.org>  Mon,  5 Feb 2001 21:36:14 -0500

lxdoom (1.4.4-3) unstable; urgency=low

  * Update lxdoom-svga to be Architecture: i386 only, as svgalib isn't
    available on other platforms.
  * Include german localizations for lxdoom-svga debconf templates 
    (Closes: Bug#84838) 

 -- Joe Drew <drew@debian.org>  Sun,  4 Feb 2001 14:56:42 -0500

lxdoom (1.4.4-2) unstable; urgency=low

  * Moved filesystem-touching stuff from lxdoom-svga's config to its postinst
    (Closes: Bug#82609)
  * .lxdoom directory no longer created as user root (Closes: Bug#50890)
  * Added README.upgrading for people who used to use extremely old versions
    of lxdoom (<1.4) (bug technically was not a bug) (Closes: Bug#80978)
  * Removed COPYING from lxdoom package (removed from Makefile.am)
  * Added documentation for remote X displays to README (Closes: Bug#52523)
  * New version of lxdoom fixes svgalib mouse problem (Closes: Bug#63043)
  * Added icon to menu system (Closes: Bug#75762)
    Thanks to Robert Ancell who took his time to create not one, but TWO
    icons for lxdoom. If someone who has more time/talent/etc wants to
    create another one, feel free!
  * Created proper lxdoom-sndserv.6 undocumented link in lxdoom-sndserv package

 -- Joe Drew <hoserhead@woot.net>  Mon, 22 Jan 2001 23:14:30 -0500

lxdoom (1.4.4-1) unstable; urgency=low

  * New upstream release
  * Remove suidmanager, add debconf
  * New things coming up: fbdoom 

 -- Joe Drew <hoserhead@woot.net>  Thu, 11 Jan 2001 23:29:39 -0500

lxdoom (1.4.2-1) unstable; urgency=low

  * New upstream release
  * Added Build-Depends 
  * Never uploaded

 -- Joe Drew <hoserhead@woot.net>  Sat, 11 Mar 2000 22:12:25 -0500

lxdoom (1.4.1-2) unstable; urgency=low

  * Back in contrib, at least until we can get some DFSG-free iwads
  * Ship lsdoom as suid by default
  * Made /etc/lxdoom.conf be removed on purge

 -- Joe Drew <hoserhead@woot.net>  Tue, 23 Nov 1999 18:02:57 -0500

lxdoom (1.4.1-1.1) unstable; urgency=low

  * Sponsored upload, minor changes
  * changed lxdoom-x to lxdoom-x11 for consistancy
  * added menu entry for lxdoom-svga
  * added hints to menu entries
  * actually copy the lxdoom manpage as lsdoom.6 so you don't need to have
    lxdoom-x11 installed to read the manpag
  * move where lsdoom's suid thingy gets installed to after dh_movefiles
  * put the package in main since it's now useful without non-free wad
    files--if used with a doom-wad-editor it can be used to make real DFSG
    free wads.  And it will be, too!

 -- Joseph Carter <knghtbrd@debian.org>  Sun,  7 Nov 1999 00:32:26 -0800

lxdoom (1.4.1-1) unstable; urgency=low

  * New upstream release

 -- Joe Drew <hoserhead@woot.net>  Sat, 23 Oct 1999 16:21:19 -0400

lxdoom (1.4.0-1) unstable; urgency=low

  * Initial Release.
  * Never uploaded. 

 -- Joe Drew <hoserhead@woot.net>  Sat, 23 Oct 1999 14:55:39 -0400

Local variables:
mode: debian-changelog
End: