1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
|
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh ${@} --parallel --with autoreconf
override_dh_autoreconf:
dh_autoreconf ./autogen.sh --
override_dh_auto_configure:
ifeq ($(DEB_HOST_ARCH_OS),linux)
dh_auto_configure -- --with-plugins=all --disable-silent-rules
else
dh_auto_configure -- --with-plugins=all,-netstat --disable-silent-rules --disable-alsa
endif
override_dh_strip:
dh_strip --dbg-package=lxpanel-dbg
override_dh_makeshlibs:
override_dh_auto_install:
dh_auto_install
rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/lxpanel/*.la
|