1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
|
DHFLAGS=--parallel
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
%:
dh $@ $(DHFLAGS) --without autoreconf
override_dh_missing:
dh_missing --fail-missing
override_dh_install:
ifeq ($(shell dpkg-vendor --is Ubuntu && echo yes),yes)
rm -f debian/tmp/etc/xdg/autostart/mate-volume-control-applet.desktop
endif
dh_install
override_dh_auto_configure:
NOCONFIGURE=1 ./autogen.sh
dh_auto_configure $(DHFLAGS) -- \
--localstatedir=/var \
--disable-silent-rules \
--disable-static
override_dh_strip:
dh_strip --dbgsym-migration='mate-media-dbg (<< 1.14.0-2~)'
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..
|