1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
|
DHFLAGS=--parallel
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
%:
dh $@ $(DHFLAGS) --without autoreconf
override_dh_missing:
dh_missing --fail-missing
override_dh_install:
dh_install
ifeq ($(shell dpkg-vendor --is Ubuntu && echo yes),yes)
dh_install -pmate-power-manager-common debian/25_mate-power-manager-ubuntu.gschema.override /usr/share/glib-2.0/schemas/
endif
override_dh_installchangelogs:
dh_installchangelogs NEWS
override_dh_auto_configure:
ifeq ($(shell dpkg-vendor --is Ubuntu && echo yes),yes)
patch data/gpm-prefs.ui < debian/patches/2000_disable_notification_prefs_ui.patch
endif
NOCONFIGURE=1 ./autogen.sh
dh_auto_configure $(DHFLAGS) -- \
--disable-silent-rules \
--libexecdir=/usr/lib/mate-power-manager \
--enable-applets \
--without-keyring \
--enable-deprecated
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..
|