1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44
|
DHFLAGS=--parallel
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
ifeq (kfreebsd,$(DEB_HOST_ARCH_OS))
SYSTEMD_OPTS := "--without-systemd"
else
SYSTEMD_OPTS := ""
endif
%:
dh $@ $(DHFLAGS) --without autoreconf
override_dh_missing:
dh_missing --fail-missing
override_dh_install:
dh_install
override_dh_installchangelogs:
dh_installchangelogs NEWS
override_dh_auto_test:
DEB_BUILD_OPTIONS=nocheck dh_auto_test
override_dh_auto_configure:
NOCONFIGURE=1 ./autogen.sh
dh_auto_configure $(DHFLAGS) -- \
--disable-silent-rules \
--localstatedir=/var/lib \
--libexecdir=/usr/lib \
$(SYSTEMD_OPTS)
override_dh_strip:
dh_strip --dbgsym-migration='mate-session-manager-dbg (<< 1.14.0-2~)'
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..
|