1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
|
DHFLAGS=--parallel
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
ifneq (,$(findstring linux,$(DEB_HOST_ARCH_OS)))
CONFIGURE_SYSTEMD = --enable-systemd
else
CONFIGURE_SYSTEMD = --disable-systemd
endif
%:
dh $@ $(DHFLAGS) --without autoreconf
override_dh_missing:
dh_missing --fail-missing
override_dh_auto_configure:
NOCONFIGURE=1 ./autogen.sh
dh_auto_configure $(DHFLAGS) -- \
--disable-silent-rules \
--libexecdir=/usr/lib/${pkgname} \
--localstatedir=/var \
--disable-static \
$(CONFIGURE_SYSTEMD)
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..
|