1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44
|
Description: Allow relocation of maxima-index.lisp
Debian policy does not allow lisp source in /usr/share/info. This
patch establishes a variable maxima::*maxima-index-dir* which when
set will provide an alternative location for the file, currently
/usr/share/doc/maxima/info.
.
maxima (5.31.0-1) unstable; urgency=low
.
* New upstream release
Author: Camm Maguire <camm@debian.org>
---
The information above should follow the Patch Tagging Guidelines, please
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
are templates for supplementary fields that you might want to add:
Origin: <vendor|upstream|other>, <url of original patch>
Bug: <url in upstream bugtracker>
Bug-Debian: http://bugs.debian.org/<bugnumber>
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
Forwarded: <no|not-needed|url proving that it has been forwarded>
Reviewed-By: <name and email of someone who approved the patch>
Last-Update: <YYYY-MM-DD>
--- a/src/cl-info.lisp
+++ b/src/cl-info.lisp
@@ -53,6 +53,8 @@
"splice a '/' between the path components given as arguments"
(format nil "~{~A~^/~}" list))
+(defvar maxima::*maxima-index-dir* "/usr/share/doc/maxima-sage/info")
+
(defun load-primary-index ()
(declare (special maxima::*maxima-lang-subdir* maxima::*maxima-infodir*))
;; Load the index, but make sure we use a sensible *read-base*.
@@ -61,7 +63,7 @@
;; with-standard-io-syntax too much for what we want?
(let*
((subdir-bit (or maxima::*maxima-lang-subdir* "."))
- (path-to-index (maxima::combine-path maxima::*maxima-infodir* subdir-bit "maxima-index.lisp")))
+ (path-to-index (maxima::combine-path (or maxima::*maxima-index-dir* maxima::*maxima-infodir*) subdir-bit "maxima-index.lisp")))
(handler-case
#-gcl
(with-standard-io-syntax (load path-to-index))
|