1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86
|
Description: mime support, gcl dlopen support, emacs keybinding change
Replace viewer commands with mime wrapper equivalents (e.g. 'see'),
add :system-p t to gcl compiler flags to support possible dlopen fasl
loading, remove maxima mode keybinding that interferes with standard
emacs usage. The first and third of these addressed long-closed
debian bugs.
.
maxima (5.30.0-1) unstable; urgency=low
.
* New upstream release
Author: Camm Maguire <camm@debian.org>
---
The information above should follow the Patch Tagging Guidelines, please
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
are templates for supplementary fields that you might want to add:
Origin: <vendor|upstream|other>, <url of original patch>
Bug: <url in upstream bugtracker>
Bug-Debian: http://bugs.debian.org/<bugnumber>
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
Forwarded: <no|not-needed|url proving that it has been forwarded>
Reviewed-By: <name and email of someone who approved the patch>
Last-Update: <YYYY-MM-DD>
Index: maxima-5.46.0/interfaces/xmaxima/Tkmaxima/Constants.tcl
===================================================================
--- maxima-5.46.0.orig/interfaces/xmaxima/Tkmaxima/Constants.tcl
+++ maxima-5.46.0/interfaces/xmaxima/Tkmaxima/Constants.tcl
@@ -135,9 +135,9 @@ set maxima_priv(urlHandlers) {
image/png netmath
image/jpg netmath
image/jpeg netmath
- application/postscript "ghostview -safer %s"
- application/pdf "acroread %s"
- application/x-dvi "xdvi %s"
+ application/postscript "see %s"
+ application/pdf "see %s"
+ application/x-dvi "see %s"
}
set maxima_priv(imagecounter) 0
Index: maxima-5.46.0/interfaces/emacs/emaxima/maxima.el
===================================================================
--- maxima-5.46.0.orig/interfaces/emacs/emaxima/maxima.el
+++ maxima-5.46.0/interfaces/emacs/emaxima/maxima.el
@@ -2488,7 +2488,7 @@ if completion is ambiguous."
(define-key map "\C-c\)" 'maxima-check-parens)
(define-key map [(control c) (control \))] 'maxima-check-form-parens)
; (define-key map "\C-cC-\)" 'maxima-check-form-parens)
- (define-key map "\177" 'backward-delete-char-untabify)
+; (define-key map "\177" 'backward-delete-char-untabify)
(setq maxima-mode-map map)))
;;;; Menu
@@ -3313,7 +3313,7 @@ To scroll through previous commands,
(define-key inferior-maxima-mode-map [(meta control tab)]
'inferior-maxima-input-complete)
(define-key inferior-maxima-mode-map "\e\t" 'inferior-maxima-complete)
-(define-key inferior-maxima-mode-map "\177" 'backward-delete-char-untabify)
+;(define-key inferior-maxima-mode-map "\177" 'backward-delete-char-untabify)
(define-key inferior-maxima-mode-map "\C-c\C-k" 'maxima-stop)
(define-key inferior-maxima-mode-map "\C-c\C-d" maxima-help-map)
Index: maxima-5.46.0/interfaces/emacs/misc/bookmode.el
===================================================================
--- maxima-5.46.0.orig/interfaces/emacs/misc/bookmode.el
+++ maxima-5.46.0/interfaces/emacs/misc/bookmode.el
@@ -680,7 +680,7 @@ file")
(and tem
(list (concat "View "(nth 1 tem))
- 'call-process "ghostview" nil nil nil
+ 'call-process "see" nil nil nil
(expand-file-name(nth 1 tem))
))
(list "Cancel")
@@ -705,7 +705,7 @@ file")
(concat
(cond ((looking-at "%PS") "")
(t "gzip -dc | "))
- "ghostview -")
+ "see -")
)))
|