1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
%:
dh $@ --parallel --buildsystem=cmake
override_dh_auto_clean:
rm -rf apidoc
dh_auto_clean
override_dh_auto_configure:
dh_auto_configure -- \
-DLIB_INSTALL_DIR=lib/$(DEB_HOST_MULTIARCH) \
-DUSE_STATIC_MBEDTLS_LIBRARY=OFF \
-DUSE_SHARED_MBEDTLS_LIBRARY=ON
override_dh_auto_build-indep:
dh_auto_build -- apidoc
override_dh_auto_test-arch:
faketime '2017-01-01 00:00' dh_auto_test
override_dh_auto_test-indep:
override_dh_auto_install-indep:
override_dh_installdocs:
dh_installdocs -X.md5
|