1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
|
include /usr/share/dpkg/default.mk
export LC_ALL=C.UTF-8
%:
dh $@ --with javahelper
override_dh_clean:
dh_clean
rm -rf antbuild/classes
override_dh_auto_build:
ant -buildfile antbuild/build.xml jar
override_dh_auto_install:
dh_auto_install
for size in 32 48 64; do \
mkdir -p debian/$(DEB_SOURCE)/usr/share/icons/hicolor/$${size}x$${size}/apps/; \
convert src/megan/resources/icons/megan$$size.gif debian/$(DEB_SOURCE)/usr/share/icons/hicolor/$${size}x$${size}/apps/megan.png; \
done
|