1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46
|
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
if [ $# -ne 1 ]; then
echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
exit 1
fi
case "$1" in
-patch) patch $patch_opts -p1 < $0;;
-unpatch) patch $patch_opts -p1 -R < $0;;
*)
echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
exit 1;;
esac
exit 0
@DPATCH@
--- a/frontends/X11/viewfax/faxexpand.h
+++ b/frontends/X11/viewfax/faxexpand.h
@@ -17,6 +17,12 @@ You should have received a copy of the G
along with this program; if not, write to the Free Software
Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. */
+/* Wed, 27 Nov 2002 00:59:35 -0500, Wolfgang Sourdeau
+ <Wolfgang@Contre.COM>:
+ - member "vres" of struct pagenode explicitly declared as "signed
+ char" instead of "char" for platforms where char is unsigned.
+ */
+
@@ -70,7 +76,7 @@ struct pagenode { /* compressed page de
char inverse; /* black <=> white */
char lsbfirst; /* bit order is lsb first */
char orient; /* orientation - upsidedown, landscape, mirrored */
- char vres; /* vertical resolution: 1 = fine */
+ signed char vres; /* vertical resolution: 1 = fine */
void (*expander)(struct pagenode *, drawfunc);
void *extra; /* used for Ximage */
};
|