1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
LIBATOMIC=OFF
ifneq (,$(filter $(DEB_HOST_ARCH), armel m68k mips mipsel powerpc powerpcspe sh4))
LIBATOMIC=ON
endif
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DMI_BUILD_STATIC=OFF \
-DMI_BUILD_OBJECT=OFF \
-DMI_BUILD_TESTS=OFF \
-DMI_INSTALL_TOPLEVEL=ON \
-DMI_OPT_ARCH=OFF \
-DMI_USE_LIBATOMIC=$(LIBATOMIC) \
override_dh_missing:
@echo ACK
override_dh_dwz:
@echo YES
|