1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58
|
export DH_VERBOSE=1
export DEBIAN_MAINTAINER=$(dpkg-parsechangelog -SMaintainer)
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
pkg=mira-assembler
exampledir=usr/share/doc/mira-examples/examples/minidemo/data/bbdataset1/
include /usr/share/dpkg/default.mk
%:
dh $@ --with autoreconf --parallel
override_dh_auto_install-arch:
make install DESTDIR=$(CURDIR)/debian/$(pkg)
override_dh_auto_install-indep:
mkdir -p $(CURDIR)/debian/tmp/usr/share/doc/$(pkg)
cp -r -t $(CURDIR)/debian/tmp/usr/share/doc/$(pkg) doc/docbook/bookfigures doc/docbook/images \
doc/docbook/doccss doc/docbook/DefinitiveGuideToMIRA.html || true
override_dh_auto_test-arch:
make check
override_dh_auto_test-indep:
override_dh_auto_build-arch:
find -name '*.ll' | sed -e 's/[.]ll$$/.cc/' | xargs rm
dh_auto_build
override_dh_auto_build-indep:
dh_auto_build --sourcedir=doc
override_dh_installchangelogs:
dh_installchangelogs src/mira/CHANGES.txt
override_dh_auto_clean:
( cd doc ; make clean ) || true
dh_auto_clean || true
find * -name Makefile -exec rm '{}' ';'
find * -name '*.xxd.H' -exec rm '{}' ';'
find * -name '*.par.H' -exec rm '{}' ';'
find * -name 'compileinfo.*' -exec rm '{}' ';'
override_dh_builddeb:
dh_builddeb -- -Z xz
get-orig-source:
mkdir -p ../tarballs
uscan --verbose --force-download --destdir=../tarballs
|