1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70
|
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --with python3,systemd
override_dh_clean:
dh_clean
rm -f debian/*.init debian/*.service debian/*.upstart debian/mistral-common.postinst debian/mistral-common.config
rm -rf debian/mistral-common.postrm debian/*.templates debian/po
override_dh_auto_clean:
python3 setup.py clean
override_dh_auto_build:
/usr/share/openstack-pkg-tools/pkgos_insert_include pkgos_func mistral-common.postinst
/usr/share/openstack-pkg-tools/pkgos_insert_include pkgos_func mistral-common.config
/usr/share/openstack-pkg-tools/pkgos_insert_include pkgos_func mistral-api.config
/usr/share/openstack-pkg-tools/pkgos_insert_include pkgos_func mistral-api.postinst
/usr/share/openstack-pkg-tools/pkgos_insert_include pkgos_postrm mistral-common.postrm
pkgos-merge-templates mistral-api mistral endpoint
pkgos-merge-templates mistral-common mistral db rabbit ksat
override_dh_auto_install:
echo "Do nothing..."
override_dh_auto_test:
echo "Do nothing..."
override_dh_install:
set -e ; for pyvers in $(PYTHON3S); do \
python$$pyvers setup.py install --install-layout=deb --root $(CURDIR)/debian/tmp; \
done
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=$(CURDIR)/debian/tmp/usr/lib/python3/dist-packages bash run_tests.sh -N -P || true
endif
set -e ; for i in logging.conf wf_trace_logging.conf ; do \
install -D -m 0664 etc/$$i.sample $(CURDIR)/debian/mistral-common/usr/share/mistral-common/$$i ; \
done
install -D -m 0664 etc/policy.json $(CURDIR)/debian/mistral-common/usr/share/mistral-common/policy.json ; \
PYTHONPATH=$(CURDIR)/debian/tmp/usr/lib/python3/dist-packages python3-oslo-config-generator \
--namespace mistral.config \
--namespace oslo.db \
--namespace oslo.messaging \
--namespace oslo.middleware.cors \
--namespace keystonemiddleware.auth_token \
--namespace periodic.config \
--namespace oslo.log \
--namespace oslo.policy \
--namespace oslo.service.sslutils \
--output-file $(CURDIR)/debian/mistral-common/usr/share/mistral-common/mistral.conf
pkgos-readd-keystone-authtoken-missing-options $(CURDIR)/debian/mistral-common/usr/share/mistral-common/mistral.conf keystone_authtoken mistral
PYTHONPATH=$(CURDIR)/debian/tmp/usr/lib/python3/dist-packages python3-oslopolicy-sample-generator \
--output-file $(CURDIR)/debian/mistral-common/usr/share/mistral-common/policy.json \
--format json \
--namespace mistral
pkgos-fix-config-default $(CURDIR)/debian/mistral-common/usr/share/mistral-common/mistral.conf keystone_authtoken auth_protocol http
dh_install
dh_missing --fail-missing
override_dh_python3:
dh_python3 --shebang=/usr/bin/python3
|