File: dev.ps1

package info (click to toggle)
mitmproxy 4.0.4-5
  • links: PTS, VCS
  • area: main
  • in suites: buster
  • size: 34,876 kB
  • sloc: python: 39,648; xml: 189; sh: 121; ansic: 68; makefile: 11
file content (20 lines) | stat: -rw-r--r-- 495 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
$ErrorActionPreference = "Stop"

$pyver = python --version
if($pyver -notmatch "3\.[6-9]") {
    Write-Warning "Unexpected Python version, expected Python 3.6 or above: $pyver"
}

python -m venv .\venv --copies
& .\venv\Scripts\activate.ps1

python -m pip install --disable-pip-version-check -U pip
cmd /c "pip install -r requirements.txt 2>&1"

echo @"

  * Created virtualenv environment in .\venv.
  * Installed all dependencies into the virtualenv.
  * Activated virtualenv environment.

"@