File: README

package info (click to toggle)
mlterm 2.9.4-5
  • links: PTS
  • area: main
  • in suites: lenny
  • size: 16,728 kB
  • ctags: 5,338
  • sloc: ansic: 74,649; sh: 8,532; cpp: 1,451; makefile: 1,126; perl: 496; sed: 16
file content (139 lines) | stat: -rw-r--r-- 2,953 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
MLTERM - Multi Lingual TERMinal emulator on X


COMPILATION
===========

  $ ./configure
  $ make

Options for configure
---------------------

  --prefix
    Installation prefix

  --without-map-table
    Remove character mapping table

  --without-prop-table
    Remove character property table

  --with-imagelib=(imlib|gdk-pixbuf2|gdk-pixbuf1)
    Use specified image library for image processing

  --with-libltdl
    load modules with libltdl

  --with-type-engines=(xcore|xft)
    Use specified type engines for rendering text

  --enable-fribidi
    Use Fribidi for BiDi rendering

  --enable-ind
    Use libind for ISCII rendering

  --enable-utmp
    Use utmp,wtmp,lastlog

  --enable-debug
    Build debug version

  --enable-optimize-redrawing
    Optimize redrawing a line

  --with-scrollbars
    Build specified scrollbars in scrollbar/ and contrib/scrollbar/ directories

  --with-tools
    Build specified tools in tool/ and contrib/tool/ directories

  --disable-dnd
    Disable XDnD.

  --disable-kbd
    Disable kbd input method for Arabic, Hebrew and Indic.

  --enable-uim
    Support uim (Universal? Input Method) if available.

  --enable-iiimf
    Support IIIMF (Internet/Intranet Input Method Framework) if available.

  --enable-m17nlib
    Support m17n library if available.

  --enable-scim
    Support SCIM (Smart Common Input Method platform) if available.

  --disable-shared
    Disable shared libraries

  --disable-static
    Disable static libraries


What you need for compilation
-----------------------------

  All you need for basic compilation is libc and Xlib.  You don't need
  internationalization support of OS because mlterm has own i18n code.

  XFree86 4.0.2 or above and FreeType 2.0.2 or above are needed for
  anti-alias.

  Imlib (1.9.x ?) or gdk-pixbuf (0.16 or higher) for background image.

  Gtk+ (1.2.x ?) for GUI configurator "mlconfig" and "mlterm-menu".

  Fribidi (0.9.0 - ?) for Bidi.

  libind for ISCII.


Supported platforms
-------------------

  Platforms tested by developers.

  * NetBSD 1.6Q current (x86)
  * NetBSD 1.6.2 (x86)
  * Debian GNU/Linux Sid, GNU libc 2.3.2 (x86)
  * Solaris 8 (x86)
  * Mac OS X 10.2 (ppc)
  * OpenBSD 3.5 (x86)
  * Fedora Core 2 (x86)
  * SuSE Linux 9.1 (x86)
  * MS Windows 98/Cygwin 1.5.13 with x-org 6.8.2.0-1 (x86)

  Following platforms are not actually tested by the author, but were supported
  in the past and are probably supported now.

  * Solaris 2.6 (SunOS 5.6) (CC=cc)
  * HP-UX 10.20 (CC="cc -Ae")
  * EWS4800 (UX/4800 R11.7) + X11R6 (CC=/usr/abiccs/bin/cc)
  * EWS4800 (UX/4800 R13.5, 64bit) (CC=/usr/ccs64/bin/cc)
  * FreeBSD 3.3R
  * FreeBSD 4.4R
  * RedHat Linux 7.1


USAGE
=====

  Read the manpage for detail.


CONTACT
=======

  Subscribe mlterm-dev-en ML
  (http://lists.sourceforge.net/lists/listinfo/mlterm-dev-en).


COPYRIGHT AND LICENSE
=====================

  Modified BSD-style license.  See LICENCE file for detail.