File: README

package info (click to toggle)
mnemosyne 2.7.3%2Bds1-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 9,804 kB
  • sloc: python: 34,077; ansic: 837; xml: 625; makefile: 249; sh: 63
file content (23 lines) | stat: -rwxr-xr-x 993 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
Instructions when installing from tarball downloaded from the Mnemosyne website:

Install the following dependencies if needed:
- Python (http://www.python.org) 3.5 or later
- PyQt (https://www.riverbankcomputing.com/software/pyqt/download5) 5.6 or
  later, including QtWebEngineWidgets.
- Matplotlib (http://matplotlib.org)
- cheroot (https://pypi.python.org/pypi/Cheroot/) 5 or later
- Webob (http://webob.org) 1.4 or later
- Pillow (http://python-pillow.org)
- gTTS for Google text-to-speech (https://pypi.org/project/gTTS/)
- googletrans for Google translate support
  (https://pypi.org/project/googletrans/) 3.0 or later.
- For Latex support: the latex and dvipng commands must be available
  (e.g. TeXLive)

These can be installed/upgraded using pip:

pip install --upgrade PyQt5 matplotlib cheroot webob pillow googletrans gTTS

Install Mnemosyne itself with 'sudo python setup.py install'.

(If Python2 is still the default on your system, use pip3 and python3)