1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
|
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
ifeq ($(filter libmm-glib-doc,$(shell dh_listpackages)),)
configure_flags += -Dgtk_doc=false
else
configure_flags += -Dgtk_doc=true
endif
%:
dh $@ --with gir --buildsystem=meson
override_dh_autoreconf:
override_dh_auto_configure:
dh_auto_configure -- $(configure_flags) \
-Ddbus_policy_dir=/usr/share/dbus-1/system.d \
-Dpolkit=permissive \
-Dvapi=true
override_dh_install:
rmdir $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/ModemManager/fcc-unlock.d
dh_install
|