File: changelog

package info (click to toggle)
modsecurity-crs 3.2.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 3,528 kB
  • sloc: ansic: 727; perl: 443; python: 371; sh: 237; ruby: 69; makefile: 14
file content (135 lines) | stat: -rw-r--r-- 4,433 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
modsecurity-crs (3.2.0-1) unstable; urgency=medium

  [ Alberto Gonzalez Iniesta ]
  * debian/control: Add Vcs-* fields

  [ Ervin Hegedus ]
  * New upstream version 3.2.0 (Closes: #943773)
  * Bump debian/compat and Build-Dep on debhelper to 12
  * Added <airween@gmail.com> to Uploaders
  * Modified fix_paths patch:
    * removed the crs-setup.conf.example related part (upstream updated)
    * added the right interpreter in the new script under util/

 -- Ervin Hegedus <airween@gmail.com>  Mon, 21 Oct 2019 19:05:16 +0000

modsecurity-crs (3.1.1-1) unstable; urgency=medium

  * New upstream release.
  * Fixes CVE-2019-11387 (Closes: #928053)

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Wed, 26 Jun 2019 08:42:44 +0200

modsecurity-crs (3.1.0-1) unstable; urgency=medium

  * New upstream release.
  * Bump debian/compat and Build-Dep on debhelper to 11
  * Bumped Standards-Version to 4.2.1.

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Tue, 27 Nov 2018 09:12:54 +0100

modsecurity-crs (3.0.2-1) unstable; urgency=medium

  * New upstream release.
  * Add "python" as Suggests to make lintian happy.
  * Bumped Standards-Version to 4.1.0. Changed Priority to "optional".

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Tue, 10 Oct 2017 09:59:46 +0200

modsecurity-crs (3.0.0-3) unstable; urgency=medium

  * Add KNOWN_BUGS file to package
  * Demote libapache2-mod-security2's Dependency to Recommends so nginx
    users can install modsecurity-crs. (Closes: #807033)
  * Move crs-setup and EXCLUSION-RULES to /etc/modsecurity/crs to ease
    user editing and package upgrading.
  * Add new file owasp-crs.load which Includes the required files to get
    OWASP CRS working.

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Wed, 21 Dec 2016 11:23:50 +0100

modsecurity-crs (3.0.0-2) unstable; urgency=medium

  * Improve README.Debian to avoid including conf files twice.

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Thu, 17 Nov 2016 13:30:39 +0100

modsecurity-crs (3.0.0-1) unstable; urgency=medium

  * New upstream release.

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Mon, 14 Nov 2016 19:17:48 +0100

modsecurity-crs (2.2.9-2) unstable; urgency=medium

  * patches/fix_826710.patch. Remove typo in rule 981063.

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Mon, 19 Sep 2016 19:43:05 +0200

modsecurity-crs (2.2.9-1) unstable; urgency=medium

  * New upstream version
  * Change Depends from libapache2-modsecurity to
    libapache2-mod-security2.
  * Bump dependency version on libapache2-mod-security2.

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Tue, 23 Sep 2014 13:22:17 +0200

modsecurity-crs (2.2.8-1) unstable; urgency=low

  * New upstream version
  * Update perl_path patch
  * Fix path to GeoLiteCity.dat (Closes: #705248)
  * Add geoip-database-contrib to Suggests
  * Fix path to arachni_integration.lua (Closes: #705249)
  * Fix path to appsensor_request_exception_enforce.lua (Closes: #705250)
  * Update debian/rules and debian/watch

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Fri, 12 Jul 2013 10:36:51 +0200

modsecurity-crs (2.2.5-2) unstable; urgency=low

  * Update debian/copyright with right license.

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Mon, 02 Jul 2012 17:18:35 +0200

modsecurity-crs (2.2.5-1) unstable; urgency=low

  * New upstream release

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Mon, 18 Jun 2012 11:44:26 +0200

modsecurity-crs (2.2.4-1) unstable; urgency=low

  * New upstream release
  * Include activated_rules/ directory for alternate way to handle
    rules inclusion
  * Bumped Standards-Version to 3.9.3

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Fri, 16 Mar 2012 17:23:57 +0100

modsecurity-crs (2.2.3-1) unstable; urgency=low

  * New upstream release

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Tue, 20 Dec 2011 07:47:43 +0100

modsecurity-crs (2.2.2-1) unstable; urgency=low

  * New upstream release
  * Added >= 2.6.0 to libapache2-modsecurity dependency (Closes: #640837)

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Sun, 02 Oct 2011 12:16:35 +0200

modsecurity-crs (2.2.0-1) unstable; urgency=low

  * New upstream release
  * Bumped Standards-Version to 3.9.2

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Thu, 16 Jun 2011 17:55:02 +0200

modsecurity-crs (2.1.2-1) unstable; urgency=low

  * Initial release (Closes: #620252)

 -- Alberto Gonzalez Iniesta <agi@inittab.org>  Thu, 31 Mar 2011 16:42:48 +0200